Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I can't modify files in Ubuntu 12.04. I'm trying to change the permissions so that I can add a folder or change a file and all I get is this:

$ sudo nautilus
sudo: /usr/lib/sudo/sudoers.so must only be writeable by owner   
sudo: fatal error, unable to load plugin
share|improve this question
    
Watch the language please –  soandos May 15 '12 at 3:12
1  
What are the current permissions for /usr/lib/sudo/sudoers.so? –  CodeGnome May 15 '12 at 3:25

4 Answers 4

Try gksudo nautilus instead.

From RootSudo - Community Ubuntu Documentation # Graphical Sudo:

You should never use normal sudo to start graphical applications as Root. You should use gksudo (kdesudo on Kubuntu) to run such programs. gksudo sets HOME=~root, and copies .Xauthority to a tmp directory. This prevents files in your home directory becoming owned by Root. (AFAICT, this is all that's special about the environment of the started process with gksudo vs. sudo).

share|improve this answer
    
I assume nautalis is a typo. –  Dennis May 15 '12 at 3:13
    
nope and nope still doesn't work the entire sudo suit doesn't work not even su. It's something to do with he permissions but without sudo it's almost impossible to change :S any ideas? –  Aaron Bishop May 15 '12 at 11:33

Assuming that the error message is accurate, and that you can gain access to root, then you should do what the message says and add write permissions to the file:

~# chmod 644 /usr/lib/sudo/sudoers.so

Alternatively, you can force a re-installation of sudo, which will reset the permissions on the files in that package:

~# aptitude reinstall sudo

If you don't have access to root via su, you can try booting into single user mode, or a chroot into your system with a recovery CD in order to effect repairs. You will definitely need some means of gaining root permissions to fix your problem, though.

share|improve this answer
    
Operation not permitted and aptitude is not installed therefore need sudo to install it ? –  Aaron Bishop May 15 '12 at 11:41
    
and the only other problem is that I'm using virtual box how do I boot into single user mode? –  Aaron Bishop May 15 '12 at 11:45
1  
@AaronBishop: At the GRUB boot loader prompt, scroll down to the "Recovery" option. This will boot you into a root terminal, or a curses menu form which you can continue into the root terminal (depending on the distro/release). Then retry @CodeGnome's chmod command. Reboot and repent. –  invert May 25 '12 at 11:27

try su - then press enter then enter password, hope this will also work for you.

share|improve this answer

Under Ubuntu, try

sudo -i  

Enter your password, then

gksu nautilus  

Nautilus will open and allow changes to folders and files.

share|improve this answer
    
The problem is that sudo itself refuses to execute, since one of its shared libs is/may be world-writable, thus weakening its security. –  Valmiky Arquissandas Aug 4 at 2:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.