Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I installed Debian beside Windows 7 in my laptop. I had an issue with GRUB not recognizing the Windows partitions at first, which I could fix by running grub-update (this found the windows partitions, but placed them at the end, AFTER the Debian install).

The laptop is configured to "Sleep" when I close the lid when logged in to Windows, and used to show me the Windows Login screen when re-opened. Now when I re-open it, it shows me the Debian login screen instead! And it does not even show the usual booting screens for Debian, even if it was shut down. I am forced to hit Restart, and choose to boot to Windows 7. It says "Resuming Windows" and again Windows starts without showing the boot screens! My problem is that when I login now, all my windows were closed, and any unsaved data is lost.

What I want is when I open the Lid, the right OS should show, namely the one I was logged in to when I closed the lid. Right now, a quick fix would be to choose the option Do Nothing when closing the lid, but this will stress the system as it will be forever on (sorry, too lazy to shut down start up everyday!) - so is there a better solution?

EDIT, UPDATE: I found that it is not "Sleep" that is the problem, but "Hibernate".The computer is fine if I open the lid a few minutes within closing - but when I leave it overnight, I think it "Hibernates" and that is causing the problem.

EDIT, UPDATE 2: Well, I am also wrong about the windows all closing up. Even if I restart from inside Debian, the System maintains all data when it hibernated... so apart from a little restart pain, nothing is really wrong. I think I should research on changing boot priorities for GRUB...

share|improve this question

1 Answer 1

I remember having a similar problem when I used to dual boot Windows/Ubuntu a few years ago... I'm pretty sure I had to edit the grub boot file.

I did a quick search on changing the default boot OS, the question below might be of some help.

http://askubuntu.com/questions/82928/how-to-make-windows-boot-first

share|improve this answer
1  
Thanks for answering, I'll check that link out - by the way, please see the update I added to the question... –  aditya menon May 15 '12 at 6:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.