Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have some strange problems with fabric deployment to Windows Server 2008r2.

The thing I try to accomplish is to copy some files to a shared folder with a fabric script (this script does a lot of other things too, but only this step gives me problems).

This is the problem:

When I try to access a UNC(Universal Naming convention) path I always get access denied kind of answers if I run the script in fabric. When I run the command in an ssh prompt (same user) it works fine.

Examples:

  • cmd: robocopy f:/.... //share
    • result: in ssh this works fine, in fabric I get "Logon failure: the user has not been granted the requested logon type aat this computer."
  • cmd: cd //share
    • result: in ssh this works fine, in fabric I get "//share: Not a directory"

Further information:

uname -a and whoami return exact the same thing in fabric and ssh.

I also tried things like mount, net use, but these commands all have kind of the same problem.

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.