Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My Mac has the wrong layout for the Spanish keyboard.

Layout Mac thinks my keyboard is:

My Spanish ISO layout

Expected Spanish ISO layout:

Expected Spanish ISO layout

As you can see from the images - the layouts are different. For example, '<' and '>' are in different locations.

Any idea how to fix this?

Additional Information I am using a Macbook Pro Mid 2009. OS - Lion - OS X 10.7.3. It does have a built-in keyboard, but thats the UK keyboard. External Spanish Keyboard is a Logitech wireless DiNovo http://www.dvhardware.net/article6438.html. I do not have any more external keyboards.

Keyboard Prefs: Keyboard Prefs

Bluetooth Settings

share|improve this question
    
This is what I get for Spanish ISO, when connecting a full sized keyboard. This is for a small sized (MacBook) keyboard. It's weird that your Spanish ISO looks different. Have you ever modified keyboard layouts? Running OS X Lion, correct? –  slhck May 15 '12 at 12:00
    
nop, brand install. Yeah, OS X Lion. My keyboard was fine before - I reinstalled the OS, and this was different. No idea what went wrong ... –  Newton May 15 '12 at 12:08
    
You have 2 keyboards connected to your Mac Book, then: the internal one and the external Bluetooth one. Keyboard viewer only shows the keyboard layout for whichever keyboard you last pressed a key on. So your screen shot of the keyboard viewer is displaying the the layout of your built-in keyboard, which is correct. Please double-check and show the Keyboard Viewer screenshot immediately after pressing the space bar on the Logitech keyboard. –  Old Pro May 27 '12 at 22:22
    
the keyboard viewer posted is taken after pressing space bar on the Logitech keyboard. If I press space bar on the internal keyboard, a different layout appears - the one I am aiming to get for the logitech keyboard! I have tried disconnecting, and reconnecting the Logitech keyboard, not sure what else is needed. I do remember, however, on the previous OS version when I used to connect the keyboard, I was asked to press the key next to the left shift button. I think it detected the keyboard based on that. I do not know where to find the same dialog box in lion. –  Newton May 27 '12 at 22:53
    
The dialog box you are looking for comes up when you click on Change Keyboard Type. Apparently under Lion that button disappears if the Mac is "sure" about the attached keyboards. I've tried running keyboard setup manually in this situation, but it just quits claiming there are no unknown keyboards. You definitely have something messed up if the keyboard viewer is showing the opposite keyboard. –  Old Pro May 28 '12 at 18:31
show 3 more comments

2 Answers

It appears the Mac thinks you have an ANSI keyboard when you actually have an Extended ISO keyboard. The layout you show as being active is the layout I see when I set my Mac Book Pro to Spanish ISO using the built-in ANSI keyboard. Probably you skipped Keyboard Setup when you installed Lion or you pressed the wrong buttons or something. In any case, it should be fixed by re-running Keyboard Setup.

  1. Choose Apple menu > System Preferences, and then click Keyboard.
  2. Click Change Keyboard Type.
  3. Follow the onscreen instructions when Keyboard Setup Assistant appears.

If the "Change Keyboard Type" button does not appear, then as a last resort you can try deleting the /Library/Preferences/com.apple.keyboardtype.plist file. First, turn off your Bluetooth keyboard, then delete it from the Bluetooth preferences, then delete the file, then reboot, then re-pair your keyboard. This should automatically bring up the Keyboard Setup Assistant.

Since you have a Logitech Bluetooth keyboard other things to try would be

  • Install, update, or re-install the Logitech drivers for the keyboard.

Note, however, that Logitech does not support your keyboard on the Mac.

share|improve this answer
    
that is interesting. However, I do not see the option Change Keyboard Type - or anything along those lines. –  Newton May 26 '12 at 22:58
    
Exactly what model of computer are you using? Which OS? Does it have a built-in keyboard, and if so, what type? What model and brand of keyboard is giving you the problem? Do you have another keyboard available? If so, what brand and type is it and does it work properly? –  Old Pro May 27 '12 at 0:58
    
I have updated the post. Thanks. –  Newton May 27 '12 at 21:51
    
last day of bounty - awarded to you for help ;) - but still facing the problem :/ –  Newton May 28 '12 at 18:09
    
Thanks, @Newton! I added a bit about deleting a plist file. I hope that does it for you. –  Old Pro May 28 '12 at 21:34
add comment

If the Change Keyboard Type button is not shown in the keyboard preference pane, you could also try running KeyboardSetupAssistant manually. See http://m10lmac.blogspot.com/2009/12/fixing-keyboard-type-problems.html:

Sometimes a machine will forget which type keyboard is attached, with the result that certain keys get transposed from what the user expects. The fix for this is run the Keyboard Setup Assistant again. Sometimes there is a button for "Change Keyboard Type" visible in System Preferences/Keyboard. If not, you can try trashing the file

/Library/Preferences/com.apple.keyboardtype.plist

Another possibility may be to open Terminal and type:

sudo open /System/Library/CoreServices/KeyboardSetupAssistant.app/Contents/MacOS/KeyboardSetupAssistant

If others were searching for how to use OS X with a Spanish PC keyboard layout, you can create a new keylayout with Ukelele.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.