Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My audio starts to periodically skip. Sometimes it starts after one day, sometimes after a few days. When it skips, the audio, and the application playing it (Winamp, YouTube, MPlayer, etc), hangs for about 20 ms and resumes.

The skipping is always at regular intervals, sometimes as close as 2 s apart, sometimes as much as 4 seconds in between.

While in this state, when I record audio with a recording program, it occasionally, but randomly, hangs for more than a whole second, and then it shows to have recorded that amount of time as silence.

This problem only started recently after I re-installed Windows (from the same CD no less).

The only solutions I've found is rebooting or going into and out of stand-by.

I already have the newest audio driver, which is a horribly old driver because DELL dropped the Windows XP support for my four-years-old laptop. It's a "Sigmatel High Definition Audio" device (I cannot find a type number).

share|improve this question
    
Your motherboard might be dying because you are killing it with XP –  Cole Johnson May 15 '12 at 18:07
    
At least it's killing it more softly than if I would've used Windows 7. –  Mark Jeronimus May 16 '12 at 4:46
    
Not really. XP wasn't as memory efficient as 7 –  Cole Johnson May 16 '12 at 14:05
add comment

1 Answer

up vote 1 down vote accepted

You can use DPC Latency checker according to its instructions to find the faulty driver.

It will show the skips as high red peaks on a moving bar chart. Keep disabling drivers and potentially services until the high peaks are gone.

share|improve this answer
    
I've already tried killing processes until there is no process left anymore that will not kill windows when killed. I could start stopping services but with the amount of services active, I hoped for a faster solution, like finding out which application is the one hanging. The description on the DSP checker site looks helpful. –  Mark Jeronimus May 16 '12 at 4:49
    
It's most likely driver issue since it causes hangs on your compputer - so it's important to disable devices (drivers) and not processes. Some services also tie into drivers so they could also be at fault though. One service I know for sure has a problem is the HP Power Assistant latest version. AFAIK it causes severe stuttering every 30 seconds on all HP laptops running that version... –  vidarak May 20 '12 at 0:07
    
It finally happened to me again. It took more than a month, the longest time I've seen so far. This tool worked, although I didn't strictly need it as I can hear the skips in the audio. After spending 30 minutes disabling/enabling service and devices, it turned out to be either of my network adapters. Re-enabling didn't bring the glitch back. Thanks. –  Mark Jeronimus Jun 26 '12 at 17:03
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.