Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just installed homebrew and as suggested, I ran the brew doctor command. I am linux newbie and do not know how to fix most of these things. But I would like to ask especially about the following error since I thought it would be fixed by what I did. The first time I ran brew doctor I got the following as one of many errors:

Error: Some directories in your path end in a slash.
Directories in your path should not end in a slash. This can break other
doctor checks. The following directories should be edited:
    /Applications/Mkvtoolnix.app/Contents/MacOS/

I deleted the Mkvtoolnix.app from my Mac using rm -r Mkvtoolnix.app. I do not see it anymore when I do ls in /Applications. However, when I run brew doctor, I still see the same error. Why is that?

share|improve this question

1 Answer 1

up vote 2 down vote accepted

You need to edit your PATH variable.

You need to start by finding where your PATH is currently being set, it is most likely ~/.bash_profile, but it could be set elsewhere.

Your PATH is the list of directories that Bash (and other shells) looks in when looking for commands. It is what saves you from having to type /usr/bin/local/programname every time you want to run programname. You merely add /usr/bin/local to your path and bash indexes everything in that folder.

share|improve this answer
1  
Thanks. That worked! –  user37473 May 15 '12 at 17:48
    
Great! Thanks for the acceptance! –  peelman May 15 '12 at 19:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.