Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I use CentOS, and for some reason, one of the servers I bought (amongst a network of other servers I do not own) is off by one hour. The time is one hour ahead no matter what time zone I set it to.

[root@adventurelobbies5 ~]# mv /etc/localtime /etc/localtime.bak
[root@adventurelobbies5 ~]# ln -s /usr/share/zoneinfo/America/New_York /etc/localtime
[root@adventurelobbies5 ~]# date
Mon May 14 18:24:23 EDT 2012

Right now, it's actually Mon May 14 17:24:23 EDT 2012

Any ideas? I've heard things about setting the hardware clock? I'm not sure if I have access to that as this is a VPS.

share|improve this question

migrated from stackoverflow.com May 15 '12 at 18:55

This question came from our site for professional and enthusiast programmers.

    
Have you issued a ntpdate to a public ntp server? – ChristopheD May 14 '12 at 21:35
    
@ChristopheD Not sure I am following. – Gray Adams May 14 '12 at 21:48
    
you use ntpdate to pull time off of an ntp server – alexhairyman May 14 '12 at 23:45
    
I don't have permission to run it. – Gray Adams May 15 '12 at 0:20
    
if you are root, you should have permission to run ntpdate unless its not installed. You can also manually set the date/time via 'date +%T -s "17:24:23"' as root, but ntpdate is better to sync with a time server. – MichaelN May 15 '12 at 14:00

You must log in to answer this question.

Browse other questions tagged .