Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My GTK fonts are very big. When I want them to look good I have to set the size to 7. But I think this is very low and not the solution. I think it should be around 12. 7 sounds like a workaround to me. Or not?

Here you can see the good looking configuration with size 7:

Preview for Size 7

And here is the very big configuration with size 12:

Preview for size 12

The problem I have is, that even if I set the size to 7 there are some programs that still display big fonts. For example, eclipse has good looking menues, but the font in the editor still is very big (but set to 10)!


Update: I have a 14 inch screen with 1600x900 pixels. According to pxcalc.com my DPI should be set to 131.13. So this looks good too.

$ xdpyinfo | grep -B2 resolution
screen #0:
  dimensions:    1600x900 pixels (310x170 millimeters)
  resolution:    131x134 dots per inch
share|improve this question
    
Did you manually change the DPI? A DPI of 131 is not normal. You should stick to the standard DPIs of 72, 96, or 120. –  iglvzx May 16 '12 at 0:27
1  
The DPI is used to make the size in points match reality. There are 72 points per inch, so at 131 DPI the fonts are going to be about twice the size in pixels. –  Ignacio Vazquez-Abrams May 16 '12 at 1:05

3 Answers 3

Something you can use in command-line and when scripting: reset DPI using xrandr:

xrandr --dpi 96
share|improve this answer
up vote 1 down vote accepted

As mentioned in the a comment: I was not able to change the DPI, so I removed the nvidia-driver and replaced it with the nouveau-driver. Now everything's fine.

share|improve this answer

Change the display DPI to a lower value.

DPI option

share|improve this answer
    
Thanks, but I don't think this is the problem. I will update my question with the output of xdpyinfo. –  Ethan Leroy May 15 '12 at 23:59
    
@EthanLeroy Does changing the DPI have any effect? –  iglvzx May 16 '12 at 0:01
    
Thanks again! When I tried to change the DPI with xrandr I got an error telling something about failed to get size of gamma for output default. My solution is quite simple: I removed the nvidia driver and installed the nouveau driver. Everything looks better now :-) –  Ethan Leroy May 16 '12 at 0:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.