Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've just done a fresh, clean install of Windows 7 on a new HD, and am experiencing the following issue:

I like to map my txt files to be opened with my editor of choice, PSPad. As usual, I have a portable installation of PSPad which I've manually moved into Program Files (x86)/development/PSPad.

When I right-click a txt file and choose Open With, PSPad does not appear in the list of recommended applications. That's expected. But when I click Browse, navigate to where the PSPad.exe file is and select it, there is still no association with PSPad and PSPad does not appear in this list (regardless of whether I have the "always use this association" checked or not).

I suspect security, ownership or read/write issues. What could be responsible for the File Association not working?

share|improve this question
    
what are some of the other issues? –  Moab May 16 '12 at 21:38
    
It's not security blocked, is it? Ex: when you download a file from the internet, and explorer prompts before the first time you run it. Explorer can't update that flag if it's in a read only location (such as Program Files). Worth double checking. –  Factor Mystic May 16 '12 at 21:43
    
Well, when I open the EXE I'm not prompted whether I wish to allow the program to execute, if that's what you mean. –  Tom Auger May 17 '12 at 13:43
    
@TomAuger - You should be able to. Sounds like you switch the default behavior at some point. I assume your system has SP1 and ALL updates right? –  Ramhound May 17 '12 at 15:56
    
@Ramhound It has SP1 and NO further updates. Do you know of a specific update that would address this issue? I'd appreciate it a TON if you could refer me to the appropriate KB#. Thanks!! –  Tom Auger May 17 '12 at 17:41
add comment

1 Answer

up vote 0 down vote accepted

I've had this problem when I installed the sublime text 3 on a system that also had 2. The issue is that you've manually moved it and windows is looking for it in the old location. Update the registry key to point to it in the new location:

  1. Run regedit (super+r, cmd, regedit, enter)
  2. navigate to HKEY_CLASSES_ROOT\Applications\PSPad.exe\shell\open\command (I'm guessing it's PSPad.exe, but whatever the actual executable file's name in should be there (so in my case it was sublime_text.exe))
  3. change the default key to "C:\Program Files (x86)\development\PSPad\PSPad.exe" "%1" (or whatever the correct path to your executable file is, in my case it was "D:\Program Files\Sublime Text 3\sublime_text.exe")
share|improve this answer
    
Thanks for the follow-up! I can no longer test this solution since I've re-imaged my drive but I'll accept it as it seems a good thing to try! –  Tom Auger Jul 8 '13 at 14:04
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.