Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Okay, so I have a hard drive which I have run into problems with. I am dual-booting Windows 7 and Ubuntu 12.04.

Recently I have been getting random crashes in both Windows 7 and Ubuntu, but much more common with Ubuntu.

Lately the crashes have become almost daily. And today when I tried to boot up I got a GRUB: Unknown File System error. I loaded up Ubuntu from USB, as Ubuntu is loading from USB I get lots of Time Out errors from the Hard drive. Once in Ubuntu I am unable to mount the hard drive, when ever I try to mount it, it just hangs (Not ubuntu, just what ever program is trying to mount, such as Gparted) and the HDD light stays lit, not blinking or anything. The file manager does detect the Windows 7 partition, but wont mount it. Doesn't detect the Ubuntu partition at all.

So, I am unable to reinstall GRUB or reinstall Windows or Ubuntu.

Am I right to assume it as failed? Or is it something else. :P

share|improve this question

Boot from a Parted Magic CD and use the supplied SMART tools to check for signs of drive failure. A large number of reallocated sectors is a common indicator of failure.

Edit: Based on the screenshot you posted, the drive seems OK. More likely is some kind of data corruption. Try running fsck and report back with the results.

Edit 2: You probably have a damaged partition table. Try using a utility like TestDisk to attempt to repair it.

Edit 3: If TestDisk has hung, your hard drive probably has failed irrespective of the SMART data. Attempt to recover data, then replace the hard drive and restore the system from backups if available. Note that the fact that the Ubuntu partition is listed twice is a sign that the partition table is damaged. Since you noted that it's moving again, give it some time; TestDisk needs to scan the entire drive, so you'll need to give it several hours.

share|improve this answer
Hey, I ran GSmartControl in Ubuntu and got this - I see a lot of pre-failure notes there. Thoughts? – Dee May 17 '12 at 2:45
"Pre-failure" values are those that indicate imminent drive failure if they are abnormal. None of the pre-failure values have exceeded limits, and there are no reallocated sectors. – bwDraco May 17 '12 at 2:49
fsck just hangs – Dee May 17 '12 at 3:11
How long should it take? TestDisk shows the Windows 7 partition correctly, but lists Ubuntu Partition twice. The quick search has been at "Analyse cylinder 19456/38912: 49%" for some time. :) EDIT - it's moving now – Dee May 17 '12 at 3:32

TestDisk recovered the Windows partition, they became mountable after the scan and I could read and write from and to it.

TestDisk reported it was unable to recover The Ubuntu Partition and ended up listing it 8 times. Since TestDisk made the drive mountable I was able to format the now unallocated/Ubuntu partition, reinstall Ubuntu and GRUB.

It now all works fine.

Any idea what could have caused this?

share|improve this answer
Register your current account and a moderator will merge your accounts (registered and unregistered) together so that you can accept an answer. – bwDraco May 20 '12 at 0:12

Probably SMART, which is set in your BIOS.

Uncheck it and load normally. You probably won't have problems again. Seems Ubuntu has SMART also and it conflicts — makes the drive really busy as well.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.