Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've got quite the question that I can't find the answer to anywhere (yet).

I use 3D studio Max 8 to do some 3D stuff (yay!). It keeps all of its files in Program Data>>AutoDesk>>3dsMax8

I was saving out a file to the RenderOutput folder within the above directory only not to be able to find it in Explorer after it saved. But when I got back in 3ds Max and choose again where to save it (save dialog) I can see the file in the location it should be (but it has that annoying lockpad icon in the bottom left of the icon).

So I can only see it (and a few other locked files) through the 3ds max menu system. This is also happening to 30+ other of my scene files in 3ds max (which is what really worries me). I tried running the program as administrator but then I couldn't see any of those files (much like what was happening through Explorer). I have turned off hidden files, and to show all OS files and still can't see anything.

Through the 3ds max save dialog I can get to the properties menu for the locked file. I've tried switching the owner of the group but when I do it says Windows can't do that as it can't locate the file. It's as if the file is hidden to even Windows!

Any ideas? Or is further clarification needed?

Thanks!

share|improve this question

1 Answer 1

up vote 4 down vote accepted

What is happening to you is UAC Data Redirection.

The user you are running 3DS as does not have write permissions to the folder you are trying to save the data to, Microsoft cracked down on these misuses of the filesystem with Vista and they added UAC Data Redirection so not to break legacy applications that assume the running user has administrative privileges (in Win XP if you tried the same thing as a non administrator user it would just give a access denied error if you tried to save in the same location).

So your data in

C:\Program Data\AutoDesk\3dsMax8\

is really being saved to

%LOCALAPPDATA%\VirtualStore\Program Data\AutoDesk\3dsMax8\
AKA
C:\Users\Fernker\AppData\Local\VirtualStore\Program Data\AutoDesk\3dsMax8\

Go check that folder and you will see all your missing files.

If you used the program as a diffrent user your files would be missing too (as it would be checking in that users %LOCALAPPDATA% folder).

If you run the program as a user who has rights to write to the folder (doing Run As Adminstrator) it never checks the %LOCALAPPDATA%\VirtualStore folder at all.

Your 2 options are:

  1. Don't save the files in locations you don't have write access to as a un-elevated user.
  2. Give the Users group write access to C:\Program Data\AutoDesk\3dsMax8\
share|improve this answer
    
Great answer! This makes sense why Windows could never see the file and why it couldn't change the permissions on the file as it thought it was there when it wasn't. I will check this later when I get home (currently at work) and will mark your answer if everything goes good (not that I don't think it will). Thanks again! –  Fernker May 17 '12 at 15:04
    
@Fernker Did it work? –  Scott Chamberlain May 18 '12 at 14:38
    
Yes it did work, perfectly. I decided to change the permissions on my 3ds directory and moved all the files from the VirtualStore into it (it's just easier to keep everything there). Thanks for the answer! –  Fernker May 18 '12 at 14:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.