Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using Google Chrome on a Ubuntu 10.04 x64 system and I just finished doing an update which got me version 19.0.1084.46 of Chrome. Now for the first time I see a message that says Adobe Flash Player was blocked because it is out of date when I open up a website that has flash.

When I clicked on the link to update the plugin it took me to a page that said: If you are using the Google Chrome browser, Adobe® Flash® Player is built-in but has been disabled. I searched some and found another page from Google that says that I should be using libflashplayergc.so as the plug-in that is integrated with Chrome.

However, I don't see that plugin in my system. My question is, is this something that I should see? Or is this plugin only for 32-bit systems and so I need to continue using the Adobe system plugin libflashplayer.so?

share|improve this question
    
please, read my answer. I solved the problem like that. –  Kyrol Feb 5 '13 at 9:33
add comment

3 Answers

Chrome(+flash) should work on 64bit OS w/o problems. Do you get that message with some specific site or every site that has flash? Can you watch youtube videos or play games/video on newgrounds.com? If you go to chrome://plugins/ you should see pepper listed there.

share|improve this answer
1  
Flash does work when I downloaded Flash Player from Adobe and put libflashplayer.so in /usr/lib/flashplugin-installer/libflashplayer.so. But what I'm wondering about is whether the built-in version of the player that Chrome's help page lists libflashplayergc.so works on 64-bit Linux, because it is missing on my system. Also I don't see pepper listed either. –  Gabriel May 17 '12 at 15:51
add comment

I have installed Fedora 16 a number of times and when I add Google Chrome (Ver 19.0.1084.46-135956) it has out of five times only installed the supposedly included libflashplayer once. This on new systems with new drives. Would be nice to know what controls that. (From google-chrome repo.)

When I install flash-plugin-11.2.202.233-release the result is the web page that has flash on it will show it on most applications that are located in the same location (as flash) and the flash material will become a live background image on those applications. Does not matter which flash site. I have 9 desktops and dual monitors.

As soon as I remove flash that phenomena goes away. (From adobe-linux-x86_64 repo.)

share|improve this answer
    
this doesn't seem like an answer to the question. it seems more like another question, please post as a question and not in the answer field of another question –  Malachi Dec 26 '12 at 18:21
    
what kinda answer is this???? –  Kyrol Feb 5 '13 at 9:34
add comment

I solved this problem right now.

as the Adobe says here:

Note: Adobe Flash Player 11.2 will be the last version to target Linux as a supported platform.
Adobe will continue to provide security backports to Flash Player 11.2 for Linux.

So, if you look in your /opt/google/chrome/you'll find a PepFlash directory, where inside there is a .so file (libpepflashplayer.so). You have to delete that folder and create a new folder called plugins where you put inside the libflashplayer.so downloadable from the link above.

If you don't want to delete the PepFlash dir, you must anyway have the libflashplayer.so as I told you (the 11.2 version, 'cause the 11.5 does not work in linux as the Adobe explain), but you have to disable the libpepflashplayer.so.

Go to chrome://plugins/ and disable the PepFlash version and the 11.5 version.

I think you might have this kinda situation:

google-chrome plugins

Let me know if you'll resolve this issue.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.