Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The title is pretty self explanatory. I have a Windows 7 environment with IIS7 installed. I'm sure this is the result of me mucking around with settings at some point. Trying to avoid a fresh Windows install.

Quick breakdown of what I've tried:

  • Resetting IEs settings back to defaults.
  • Using the IP address of the machine vs. localhost. Using the IP does work.
  • Pinging localhost. I can, which isn't surprising because Firefox/Chrome have no problem resolving it.

Any other ideas?

share|improve this question
1  
Can you try again with IPv6 disabled? I suspect a broken IPv6 setup. –  Gurken Papst May 17 '12 at 20:37
    
I actually saw this suggested elsewhere so my IPv6 is already disabled for the Wireless NIC I'm using to connect to the internet. –  vpiTriumph May 17 '12 at 20:51
    
I must admit that I don't know how Windows is handling loopback connections in detail, since there is no dedicated loopback adapter. So just to be sure, disable IPv6 support on all NICs (or temporarily remove the protocol entirely). –  Gurken Papst May 17 '12 at 21:30
    
Disabled on all. Still no luck. Could this possibly have to do with my Hosts file? I searched for what a default one should look like in Windows 7 and mine appears to match. –  vpiTriumph May 17 '12 at 21:39
    
Okay, after a bit more wasted time I realized I had clicked 'Restore advanced settings' as opposed to the more encompassing 'Reset Internet Explorer settings' similarly on the Advanced tab. Once I did this, I'm back in business. Thanks for the effort guys. –  vpiTriumph May 18 '12 at 14:26

4 Answers 4

Is localhost in the correct security zone for Internet Explorer? Security zone settings apply only to IE and several other Windows-specific applications, so this may explain this problem.

share|improve this answer
    
I had localhost listed in my Trusted Zone. This shouldn't cause a problem but I cleared it just to be safe. Didn't make a difference unfortunately. –  vpiTriumph May 17 '12 at 20:49
up vote 2 down vote accepted

After a bit more wasted time I realized I had clicked 'Restore advanced settings' earlier as opposed to the button under the more encompassing 'Reset Internet Explorer settings' similarly on the Advanced tab.

Once I did this my localhost once again works correctly.

share|improve this answer

maybe you need to add some exceptions(addresses) that you do not need to access via proxy. Just like the pic attached.

share|improve this answer
    
You can't post images. Post me a link in the comments and I'll embed it for you if it has to be. Or can you edit your answer to be more clear even without a picture? –  slhck Jun 12 '12 at 19:46

I had to add the domain name (http://local.example.com) to "Security" > "Local Intranet" > "Sites" > "Advanced" before I could access it in IE 11.

share|improve this answer
    
Hello and welcome to superuser.com. Does you answer also apply for IE9? –  Mogget Nov 14 '13 at 20:45
    
@Mogget: Sorry, I only have IE 11. –  pcoucke Nov 20 '13 at 14:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.