Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

UPDATE: As my patience started to end, the laptop started to display symptoms of other malfunctions, so I ended up returning it to Asus and actually had the price of the laptop back in store credit. I did not solve the problem per se, but as I don't have the notebook and the screen, the keyboard, the touchpad and other parts were malfunctioning, I can safely assume that it was put to rest. I don't know how to behave when my question isn't actually answered, but was "solved", so I placed this over here. Anyone that knows how to end this topic, I would appreciate the heads up. Thanks for everything, everyone, it's nice to see that this topic in the community was active even when all this time had passed.

  • vinir

    So I bought an ASUS K43E notebook earlier this year and built a wireless conection to link it to. It worked great for the first weeks, but then I updated my Windows 7 Home Basic with the daily updates; After that my home network couldn't be reached no matter what I did. I have linux on dual boot on the same notebook and it can connect to my home wireless network flawlessly. I have a hunch that it's somehow related to the Network Profile settings. I have noticed my network was set as "Home network", but after the system updates I got changed to "Public". Now I can't connect to it to change the profile settings.

My Atheros Network adapter is updated to the latest driver (march 2012), and I still can't connect. The funny thing is that the same thing happened to my mother's notebook, as it has the same Network Adapter, Atheros AR9285, as I recall it. I managed to fix it on my mother's computer by using an specific network LSP and profiling reset that was available through her notebook's antivirus program, avast! Internet Security. I can't get that to work on my notebook, but I suspect that some related tool might just make it work too. So the question is: how to modify a network's profile and settings that were stored in my notebook? I can't connect to the specific network on Windows, as stated before.

share|improve this question
    
"no matter what I did" - please detail what you have already tried and the results, so that we don't go through cycles of "try this" and you respond "I already did". –  sawdust May 17 '12 at 23:48
    
Often there can be issues between windows own "wirless zero configuration" stuff, and specific software for the wirless adapter. so far I have seen and got best results from configring these things with only the winders software, and removing the other wirless software, and just using its "driver" for the adapter. Sorry i dont know how that applies in your situation, but mabey you do? some of those firewall security programs also configure TO what they see on install, as that changes , they no longer are trapping/hooking correctly –  Psycogeek May 18 '12 at 0:56
    
What I already did was uninstall drivers, revert drivers to older states, looked up some things in the registry -apparently some information regarding older network profiles seem to stack over there, I thought it could mean something. I don't remember everything I did, so in case I already tried it, I guess I'll be redoing and hearing everything again; I really don't mind, as I'm new to Win7 and could use all the help. Maybe I missed a certain thing, you never know. –  vinir May 18 '12 at 4:03
    
Is there some kind of software that resets your profiles and network configuration? I would like to be able to set my connection on whether "Home", "Work" or "Public" again. I'm stuck with the Public profile even though I have no active wireless connections. How to set up that network discovery assistant again? I might be wrong, but I believe that is related to my issue in some way. –  vinir May 18 '12 at 4:16

4 Answers 4

I had this problem after installing the recent windows update on my ASUS U512F laptop. I was able to connect to the network but not the internet. All of my other gadgets were able to connect without a problem. I tried all that I could possibly think of in my limited knowledge of networking settings. The only thing that worked was to uninstall the recent updates for windows.

share|improve this answer
1  
Can you specify which "recent" updates you removed? As this answer ages, it will become difficult for anyone who comes across it to figure out which updates may have been in conflict. –  MaQleod Oct 3 '12 at 17:04

you can remove and recreate existing wireless profiles by going to the networking section in your control panel:

Control Panel\Network and Internet\Manage Wireless Networks

Try removing the wireless profile and connecting again to see if you're able to actually connect.

share|improve this answer
    
I erased the profile and I still can't connect. –  vinir May 18 '12 at 4:11

I had this exact problem and the only solution I have been able to come up with is to restore to a point before the update. It was really weird because I could connect to the network through a ethernet connection but the wireless would not work

share|improve this answer

Most likely if any other method failed you may have a gateway problem. Windows sometimes uses a hard coded gateway ip adress in the adapter settings and override user settings. It happens to me when I changed my main board and suddenly Windows didn't connect automatically to my wireless router. I needed to manually edit my adapter configuration after each shutdown. I fixed my problem with deleteing the gateway ip address in the registry. You can Google for windwos hard coded (automatic) gateway ip address.

share|improve this answer
    
Yes, somehow I managed to do that more than once, but then, as I updated Windows again, it would return to fail when connecting. I do not remember how I found and which registry key I changed, so every time I tried again I would was involved in this trial and error thing. I actually formatted the laptop once, so if it came to that again, it wouldn't actually be a problem. However, I finally gave up and returned the laptop, as it started to display other problems. –  vinir Oct 3 '12 at 20:56

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.