Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Good day.

I have a Slackware Linux VM that I run on my laptop. I have it setup to use both my laptop screen and an external monitor in full-screen mode so my guest OS can use both screens simultaneously.

A script provided by VMware tools tricks my guest VM into thinking it has a larger screen than it really does. If my laptop screen is 1400x900, and my external monitor is 800x600, the script treats this as if I have one screen that is (1400+800)x(900+600) = (2200x1500) pixel screen.

In a few applications, namely Firefox, the size of the font stays the same regardless of how many monitors I am using (but only in the browser contents; the titlebars are tiny). If I use any other apps, like Konsole, OpenOffice, Konqueror, etc, the fonts are really tiny when I'm not using my second monitor, especially fonts used for menus, titlebars, dialogs, etc.

I've had to edit font sizes in a number of locations since some apps use KDE's libraries, others from gnome, etc. Is there a way to consolidate all of my font sizes so that my fonts are the same physical (apparent) size regardless of my virtual screen size. I've included the contents of my ~/.*rc files for reference. My guess is maybe I can set a font size as a fixed value instead of as a percent of the screen size, somehow.

Thank you all in advance for your time and assistance.

~/.kderc

[General]
activeFont=Sans Serif,4,-1,5,50,0,0,0,0,0
desktopFont=Sans Serif,4,-1,5,50,0,0,0,0,0
fixed=Monospace,4,-1,5,50,0,0,0,0,0
font=Sans Serif,4,-1,5,50,0,0,0,0,0
menuFont=Sans Serif,4,-1,5,50,0,0,0,0,0
smallestReadableFont=Sans Serif,4,-1,5,50,0,0,0,0,0
taskbarFont=Sans Serif,4,-1,5,50,0,0,0,0,0
toolBarFont=Sans Serif,4,-1,5,50,0,0,0,0,0



~/.gtkrc-2.0

style "font"
{
    font_name = "Monospace 3"
}
widget_class "*" style "font"
gtk-font-name = "Monospace 3"
share|improve this question

1 Answer 1

up vote 1 down vote accepted

Try using VirtualBox instead of VMware.

VMware uses the "vmware-tools-user" script to setup all of you physicals displays as a single large desktop. Quoting your example above:

If my laptop screen is 1400x900, and my external monitor is 800x600, the script treats this as if I have one screen that is (1400+800)x(900+600) = (2200x1500) pixel screen.

That's going to make your fonts appear smaller regardless, and is a pain to deal with.

If you go with VirtualBox, it creates multiple virtual displays which can be enumerated via xrandr (ie: VBOX0, VBOX1, etc). This allows you to have multiple monitors with reasonable resolutions, rather than one massive virtual monitor with an absurdly large resolution compared to your individual monitors. This becomes especially tedious if you have a three-monitor setup, as some KDE applications won't let you set the monitor size any smaller than size 4 font, meaning you are stuck with large/disproportionate fonts.

To conclude this, you should simply rename your KDERC (if you are using the latest/current version of Slackware, it's not needed), and your gtkrc/gtkrc-2.0 files are sourced from the auto-generated settings in KDE.

From there, you can just update your KDE/GTK font sizes via the systemsettings command.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.