Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am attempting to VNC into a Mac Mini 2010 from an Ubuntu 12.04 desktop. I've tried RealVNC, gtkvncviewer and TightVNC java. Tight vnc is the only one that gives me a password prompt. I've been told this is because mac runs tight vnc when on remote desktop. Anyway so tight VNC that I downloaded from tightvnc.com won't work.

I tried to telnet the VNC address

jasonfonseca@ubuntu:~$ telnet 192.168.6.206 5900
Trying 192.168.6.206...
Connected to 192.168.6.206.
Escape character is '^]'.
RFB 003.889
^C
^]

I got a response, so the service is contactable. When I use tight vnc, it connects and prompts for a password. When that goes in, the windows disappear. TightVNC is still running in my htop, but no window for it. Gone.. disappearing act. Also the icon on my launch bar is also gone.

Any help appreciated.

share|improve this question

1 Answer 1

I found this little nugget. Give it a try, and see if it makes a difference.

From Setting up VNC on MacOS

If you are NOT connecting with JollysFastVNC or ScreenSharing you need the following steps:

  • Click Access Privileges to open the more advanced options.

  • Check on VNC viewers may control screen with password and define a password.

This is at the point where you activated it.

Otherwise, if you want to try JollysFastVNC, download it there.

Of course, if you have already enabled this, and/or Jolly'sFastVNC doesn't work for you... this answer is useless.

EDIT I found this to be interesting, posted on the JollyFastVNC page...

Lion users: If you are connecting to a Lion machine, make sure to use Mac Authentication (hold down the alt/option key when clicking connect to reselect the authentication scheme). Lion has a bug with normal VNC authentication.

share|improve this answer
    
»Check on VNC viewers may control screen with password and define a password« – good to know! –  Stefan Schmidt Dec 28 '13 at 20:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.