Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My laptop got a virus and after removing it, the laptop batteries no longer charge.

I tried reinstalling the drivers in the device manager for Battery→ “Microsoft AC adaptor” and →“ACPI Compliant Control Method Battery”, but without success.

What could be the problem?

share|improve this question
Do the batteries charge when the system isn't on? If so this has absolutely nothing to do with the software and is just a coincidence. – Shinrai May 18 '12 at 14:13
@Shinrai You mean "if not"? Because if it does charge when off, then it is likely software related. – Bob May 18 '12 at 14:23
@Bob: I think you misread Shinrai (or a comment edit beat you), though it is a bit convoluted in negations, so it's understandable :-) . "If it charges when turned off, then it is not related to software." – Daniel Andersson May 18 '12 at 14:28
the laptop battery does not charge when the laptop is powered off and plugged in – Nathaniel_613 May 18 '12 at 14:36
@Bob - I did mean 'if not'. – Shinrai May 18 '12 at 14:50
up vote 5 down vote accepted

If the battery does not charge when the laptop is powered off, this has to be a hardware problem. Either the battery is defective, the power supply you're using isn't providing enough power for the system to charge the battery, or the charging mechanisms inside the laptop are damaged in some manner. The virus is purely coincidence - software problems cannot affect what happens when that software isn't running.

share|improve this answer

While it looks like a hardware fault, it could also be the embedded controller/charge controller being in a undefined state. While this would probably also be just a coincidence, there might be malware interfering with the embedded controller. Your removal steps (which are unknown to us) might also have had an impact.

To restart the embedded controller, disconnect power supply, remove battery an try to power on the laptop. This obviously will not work, but helps to discharge capaciators powering the controller. Then reinsert battery and connect power supply again and see if it begins to charge. If not, the controller might have been running without interruption despite of the power-on attempt. In this case repeat these steps but wait some time (maybe one day) before reinserting/connecting.

share|improve this answer
I tried your suggestion without any success In my intitial question, I neglected to mention that I get the following error message in a DOS screen when I bootup the laptop: “the AC power adaptor or wattage cannot be determined. The system will adjust the performance to match the power available. Please connect a Dell 65W AC adaptor or greater for the best system performance. press the F1 key to continue F2 key to run setup utility”.I have already tried using 2 different OEM power supply adaptors and 2 different OEM laptop batteries.My operating system is Vista 32bit – Nathaniel_613 May 18 '12 at 20:09
@Nathaniel_613 - That's a pretty big hint! Probably the actual input for the power adapter (that is, the assembly where it plugs into the system) is damaged in some way. – Shinrai May 18 '12 at 22:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .