Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Folks, My Windows 2003 Server machine maps a shared network folder to a drive letter. For example:

\\\d$\logs maps to Z:

I am able to get to this drive using the Windows commandline. This also used to work with Cygwin 1.5. After the upgrade to 1.7, none of the following works from Cygwin:


When I list the mountpoints in cygwin, by typing mount, I don't see the Z drive. I do see the physical drives:

C:/cygwin/bin on /usr/bin type ntfs (binary,auto)
C:/cygwin/lib on /usr/lib type ntfs (binary,auto)
C:/cygwin on / type ntfs (binary,auto)
C: on /cygdrive/c type ntfs (binary,posix=0,user,noumount,auto)
E: on /cygdrive/e type ntfs (binary,posix=0,user,noumount,auto)

I tried to manually mount the Z drive: mount Z:/ /cygdrive/z/ -o posix=0 This brings up Z drive in mount listing as "unknown" and I still cannot cd into it:

Z: on /cygdrive/z type unknown (binary,posix=0,user)

How do I make this drive show up? Any ideas?

Thanks for your help and insights.

share|improve this question

Share Mounts are running in the user context and are not necessarily available to all processes (especially if you run the cygwin process under another account for example).

While there are possibilities to mount the share in cygwin, wouldnt it be sufficient to simply access it? You can use the following notation:


share|improve this answer
Thanks leepfrog. It probably would, but this would require changing an application that used to work before. Is this not supported in 1.7.15? – user49692 May 19 '12 at 0:15
I have just verified this with my local installation (also 1.7) and it works there without issues. You could try to run /bin/copy-user-registry-fstab from cygwin once and then test again – leepfrog May 19 '12 at 23:23
Note: Run net use in cmd to get those paths – VarunAgw Jan 6 at 15:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .