Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Suddenly my laptop (Acer Aspire 7740) (windows7) keyboard is malfunctioning. The output does not match the actual input i type.

When I type: A B C D E F G H I J K L M N O P Q R S T U V W X Y Z ` 1 2 3 4 5 6 7 8 9 0 - = [ ] \ ; ' , . /

i get the output A B DC DC DC GF GF HN M, J M, . €M, HN . €P Q GF SX T U V SX SX HN Z a 1 sx 3 dc gf hn / - / ] / \; ' m, .€ / \;

Even enter and backspace \; give me the following outputs: \; \;

Left arrow functions as the tab button.

Use of a external keyboard gives me the correct output so I am not able to understand what is the problem. I tried cleaning the keyboard and pressing fn+numlock or fn+shift+numlock. This also did not solve the problem.

Thanks for any help you can give.

In response to the comments and answers uptil now:

The problem started after probably 5 hours of inactivity. Do not find any spillage. None of the keys are stuck and feel normal / move freely. Multiple keyboards are not enabled so I dont think that is the problem too. Thanks for your suggestions.

share|improve this question
3  
How sudden? In the middle of use, or after a period of inactivity? –  Bob May 19 '12 at 11:19
    
Did you spill something (especially a carbonated beverage) on the keyboard? If so, it's probably toast. Otherwise, look for a key that's stuck -- operate all keys a couple dozen times, and make sure they all "feel" the same. –  Daniel R Hicks May 19 '12 at 13:04
    
(I assume you tried powering completely off and rebooting.) –  Daniel R Hicks May 19 '12 at 13:05
    
The problem started after probably 5 hours of inactivity. Do not find any spillage. None of the keys are stuck and feel normal / move freely. Multiple keyboards are not enabled so I dont think that is the problem too. –  Dave May 19 '12 at 14:57
add comment

1 Answer 1

A possibility is that you have defined multiple keyboard layouts and have accidentally switched by pressing <CTRL> and <SHIFT> together.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.