Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The fact is that it doesn´t happen always. It is working normally and suddenly it start to fail. When it happens other keys work well, but these 4 not. It's Windows 7 on a Lenovo 420 laptop, but the problematic keyboard is a IBM type M keyboard connected to a Trendnet KVM. The keyboard of the laptop is working fine.

share|improve this question
    
does the keyboard work fine in another computer without a KVM? –  ncdownpat May 19 '12 at 17:41
    
No, I have connected it to the laptop without the KVM and the problem persists. –  fdediego May 26 '12 at 19:02

1 Answer 1

up vote 1 down vote accepted

If the keyboard has the same issue with other computers, not connected through a KVM, then this really sounds like to me that there is some sort of conductive material getting in the way periodically, like a small drop of water or something of the sort, within the keyboard.

If it works correctly, then it could be a problem with the KVM forwarding the keyboard signals.

Because we are using 2 different components here which could be the source of the fault, I would recommend attempting to isolate which component is failing by eliminating one of the variables. Either replace the keyboard or the KVM and and go about your work as usual to see if the failure ever happens again.

share|improve this answer
    
I have connected it to the laptop without the KVM and the problem persists. Now it happens always. I don't understand why they work alone and with "right-shift", but they don't work with "left-shift" –  fdediego May 26 '12 at 19:06
    
The problem is in the keyboard. With another one the same laptop works fine. –  fdediego May 26 '12 at 21:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.