Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Is it possible to disable copy/paste on VNC Server? I would like to allow a user to connect but not be able to transfer files or copy/paste anything out. While transfer files can be blocked (at least on UltraVNC) I don't see an option to block copy/paste?

Or maybe any of those products (Mikogo, LogMeIn Free, Real VNC, tight VNC, any other) allows exactly that? RDP isn't an option.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Well, while using RealVNC server, I can go into the server options, choose the inputs tab, and uncheck the "send clipboard updates to clients" option. After that, whatever I attempt to copy from the server won't paste over to the client. However, I can turn that feature back on while connected with the client... so it only keeps people from copying if they don't turn the option back on themselves. I suppose you could hide the tray icon

To disable the tray icon, you should start the "regedit" utility from the command line, go to the HKEY_LOCAL_MACHINE\Software\ORL\WinVNC3\ folder, and create a DWORD parameter with the name "DisableTrayIcon" and the value "1". Then, after restarting (the)VNC Server, the icon will not be shown anymore.

...or just use AllowProperties to disable access to changing the settings.

TightVNC... no mention there of controlling access to the clipboard.

I notice this setting is conspicuously absent in UltraVNC as well.

Don't know about LogMeIn... so I'll set up an account and see... and done. File sharing is easy... and not something you appear to be able to disable. No mention in the settings at all about the clipboard.... But... whatever you copy in the remote session can be pasted into the local session. And oddly enough, following their instructions to share a file ( a text file called new.txt sitting on the desktop of the remote computer) fails. I am given the error that I cannot share that file and if it is on a network resource I need to copy it to the actual machine. I'll have to investigate that.

Mikogo isn't remote desktop sharing. It's presentation. The person who connects (and is not the presenter) can view whatever is opened on the desktop. They can't open new files, etc. They can't select what is shown. When they are changed to being the presenter, the desktop view is switched to see THEIR desktop. So... when using Mikogo, you are either viewing what someone wants to show you on their computer, or you are showing yours.

So... it looks like using the advanced settings in VNC to alter what parameters can be changed/turned on and possibly even hiding the VNC icon is the way to go.

share|improve this answer
    
They don't have have admin rights so if I disable it on Real VNC it should disallow them to switch on/off settings. As for Mikogo you can control stuff on the desktop when you are given an option to, but it doesn't have option to disable Copy/Paste. Thanks –  MadBoy May 20 '12 at 20:54
    
yeah... with mikogo I didn't go all that far into it... just a quick install and meandering around the software for a few minutes. –  Bon Gart May 20 '12 at 22:07
    
Thanks for all that. You did a great job! –  MadBoy May 20 '12 at 22:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.