Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a VM on my laptop that runs Windows Server 2008.

Both my laptop and my VM are connected to my office domain network, and I use NAT network for my VM.

From my VM, I can ping to my laptop, but from my laptop, I cannot ping to my VM.

I try to ping my VM with its hostname, and my laptop are able to detect the hostname IP, however, it still unable to ping the VM.

share|improve this question
up vote 1 down vote accepted

By default Windows Server 2008 is set to not respond to ping replies. To enable it;

Go to Window Firewall with Advance Settings from Administrator Tools menu.

Look inside Inbound Rules, scroll down to File and Printer Sharing, right click and enable the one with Echo Request - ICMPv4-in rule.

Make sure the icon is green.

Ping your server.

share|improve this answer
    
Hai beano, I try it and still, my laptop cannot ping my vm – chrisma andhika May 21 '12 at 7:47
    
There is another odd thing. The IP segment of my office building is 10.10.20.xxx. My laptop gets the right IP, but my VM gets IP 192.168.23.xxx. – chrisma andhika May 21 '12 at 7:54
    
Ah, you have a NAT'd address on your VM, try changing the network type on the VM to bridged. – sgtbeano May 21 '12 at 8:22
    
Thanks Beano, now it works – chrisma andhika May 22 '12 at 14:04
    
Hey, no problem - glad it works – sgtbeano May 23 '12 at 15:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .