Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am unable to connect to my Windows 7 machine via RDP. I also can't ping it.

Is there something special I need to configure?

share|improve this question

migrated from serverfault.com Jul 16 '09 at 0:55

This question came from our site for system and network administrators.

3 Answers 3

You need to enable Remote Desktop.

Right click My computer > Properties.

Choose Remote Settings on the left.

Select the Remote Desktop setting you require.

If the user you wish to be able to Remote Desktop is not a member of the Local Administrators group, you will need to click on the Select Users button on the same page, and add the user the the Remote Desktop Users Group.

If you need this to work over a WAN connection, you will also need to open port 3389 on your (hardware) firewall and point it to the LAN address of the Windows 7 machine.

share|improve this answer
2  
Just as a side note, RDP is only available on the Professional (and higher) versions of Windows. Home versions are out of luck. –  heavyd Aug 9 '09 at 5:23

You need to ensure that your firewall is configured to allow in RDP connections, add an exception for the RDP application, or for port 3389.

You also need to ensure RDP is enabled on the machine, right click on my computer, go to properties and into remote settings.

share|improve this answer

To go with the above comments, if you are trying to RDP from WAN side into your home box, there is a good chance that you have a dynamically assigned IP address and your WIN7 Box is under a NAT by your firewall/router. You may have to install a service like DynDNS that will continuously update your Dynamic IP and also map it to a url. After you can find your home firewall/router, with RD enabled and Port Forwarding/Port Opening of 3389, you should have no problems.

I would caution you, though, that RDP is not a very secure method of doing this. You may want to look into installing SSH through cygwin or CopSSH, creating an encrypted tunnel, and then RDPing through that. Good luck.

share|improve this answer
    
it's secure enough, especially with a long password. –  djangofan Oct 21 '09 at 17:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.