Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

A partition of my NAS is full:

XX.XX.XX.XX:/nas-XXXX/backup   701G  701G     0 100% /home/nasBackup  

I can't delete a file. I get an error:

disk quota exceeded

I tried this:

cp /dev/null one_of_my_file.tar.gz

But it doesn't work. How can I regain control of my disk?

share|improve this question
Which NAS do you have? – sgtbeano May 21 '12 at 8:14
this one : This is NFS Protocol – Epharion May 21 '12 at 8:24
Does this NAS have a management interface? Perhaps you can delete some files through that? It might run as a privileged user on the NAS which has less limitations. – Bram May 21 '12 at 9:18
The only thing that I can configure are partitions... – Epharion May 21 '12 at 9:42
@akira: using /dev/zero is not going to help here. in fact, this would cause a file to be created that would take up as much disk space as possible. the only reason that /dev/zero works when erasing a disk is that the disk has a physical end and returns an error, stoping the copy. /dev/null is the correct source here because it results in a 0 length file. – longneck May 21 '12 at 16:19

If your NAS has CD/DVD access run live boot of any Linux. Mount the drive and work with it that way.
If this isn't possible, remove the drive and attach it to one of your Linux boxes.

share|improve this answer

You can try:

> file

This command will clear all data in file.

share|improve this answer
It doesn't work. I got the same error. – Epharion May 21 '12 at 8:30
do you connect nas server, may be you can delete in server. – kelebek May 21 '12 at 8:39
I'm connected on my linux server. – Epharion May 21 '12 at 8:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .