Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have two wireless APs on the same network. Most of the devices here are roaming seamlessly including two android phones and one windows 7 laptop, but my laptop (also windows 7) is only ever connecting to one of the APs, even when it has very low signal and the other AP is right next to it.

Using inSSIDer, I can see the better signal coming through very very strong, but I was wondering if there's any way to force windows to switch to the stronger AP?

share|improve this question
    
I solved my problem, but my solution doesn't answer my question. The way I solved my problem was that I had different security options - both were WPA2-Personal-PSK, but one was AES and the other TKIP. Setting both to the same allowed this laptop to roam too. Strange the other devices had no issue though. –  Lynden Shields May 21 '12 at 9:01
    
It sounds as though you solved your problem which feels like a "best answer" to me. Could you please add your solution as an answer to your question and then accept it? Answering your own question to complete it is perfectly acceptable, even encouraged (if a better answer is not available). See It’s OK to Ask and Answer Your Own Questions. (This blog entry is also referenced in this faq section.) –  irrational John May 21 '12 at 17:59
    
I feel like someone who has found my question isn't going to be looking for the solution that worked for me, that's why I hesitated to answer my own question. I still don't quite think it's right to. –  Lynden Shields May 21 '12 at 21:41
    
I don't know if it is heresy to suggest this or not, but I've sometimes had good luck with rather technical wireless questions at smallnetbuilder.com. The main drawback might be that they tend to only approach things from a Windows or sometimes a Mac perspective. But if you were also having this problem in Windows ... if the question is primarily about Wifi ... then you might have some luck there. I'm not certain there is a way to do what you are asking. Wouldn't automatically switching be part of the 802.11 protocol? –  irrational John May 21 '12 at 21:54
    
Yeah I'm beginning to think that the answer is probably "You can't" but I was waiting for someone more knowledgeable to pipe up and say it, with backup. –  Lynden Shields May 21 '12 at 21:58

2 Answers 2

You should set both AP's to use the same SSID. This should allow the clients to choose the strongest signal automatically. However, you should note that the logic used by different chipset vendors varies massively and this may or may not work with all chipsets.

share|improve this answer
    
Yep they're set to the same SSID - otherwise the other devices wouldn't roam seamlessly –  Lynden Shields May 21 '12 at 13:03
up vote 2 down vote accepted

I solved my problem, but my solution doesn't answer my question. The way I solved my problem was that I had different security options - both were WPA2-Personal-PSK, but one was AES and the other TKIP. Setting both to the same allowed this laptop to roam too. Strange the other devices had no issue though.

share|improve this answer
    
I had the same issue. Two access points with the same SSID on the same network but a Windows laptop that wouldn't roam between the two. Setting both AP to the same encryption settings fixed it. –  Alexandre Jasmin Oct 6 '13 at 17:07

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.