Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've got a couple of shortcuts on my desktop and on some of them I've configured the "Shortcut key" to a keyboard combination. For example I have a shortcut pointing to d:\documents\todo.txt and I've set Shift + Alt + T. This naturally opens up using notepad.

Double-clicking on the icon always opens up the text file immediately. Using the keyboard shortcut though is sometimes very (5-10 seconds) slow. Note that during that time CPU utilization does not rise.

This happens to all my machines (both old and new ultra fast boxes) in Windows XP (various versions) and Windows 7.

There are tons of questions about this but no solution.

Is there an explanation and solution to this problem?

Edit: The behavior is not consistent. I have 30 desktop shortcut and 5 of them have keyboard shortcuts assigned. I'm not interested in software alternatives for this Windows functionality. I want to know what the problem is and how to solve it.

share|improve this question
    
Does this happen when booting in Safe mode? If not, then try turning off your antivirus or other security products. If this helps, tell us which product caused this. –  harrymc Jul 30 '13 at 15:14
    
@Psycogeek: Good observation but D: or a sleeping drive doesn't have anything to do with this. –  cherouvim Aug 4 '13 at 5:10
    
If I was observing a little closer :-( , I would have noticed that your shortcuts are working fine. It is only the Keyboard shortcuts that have the delay. None of your "windows" own Key commands are slow right? –  Psycogeek Aug 4 '13 at 5:32
    
Could you remark on my comment above? –  harrymc Aug 4 '13 at 6:29
1  
I killed "SetPoint.exe", Logitech's mouse parameters software, and it resolved my problem –  Goldorak84 Sep 23 '13 at 15:56

9 Answers 9

My personal experience was that there was a program that was delaying Windows' handling of the hotkey. For myself it was Steam, for Andreas it was Akamai.

To diagnose which application is responsible simply close an application and try your hotkey again. Once you figure out who the culprit is, decide whether it's a service that you can deal with not running at all times.

I know this is a fairly old question, but after not finding an answer I stumbled upon the solution and felt the need to share it with the community.

share|improve this answer
    
For me it was setpoint.exe, logitech's mouse software –  Goldorak84 Mar 24 '14 at 16:56
1  
I have this problem in Windows 10 now. "Application Frame Host" is the culprit. –  Peter Quiring Aug 14 at 13:00
    
FWIW, Adobe Creative Cloud has caused this problem for me, sometimes introducing as much as a 30-second delay to every app launch. However, I'm now experiencing the problem under a fresh Windows 10 install with Adobe CC disabled. Investigating that problem independently... –  Andy Giesler Aug 14 at 14:58

The original question deals with Windows 7, but it's happening now for a new reason in Windows 10. Here's a general answer that deals with both situations.

The general problem

There's an excellent explanation of the problem and its cause at the 2012 MSDN post Why is there sometimes a long delay between pressing a hotkey for a shortcut and opening the shortcut?

Executive summary: before launching a program via its shortcut key, Windows first polls all currently running programs and asks "Is this your shortcut key?" If so it switches focus to that window rather than spinning up a new copy of the program.

The problem happens when a window somewhere refuses to answer the question. This can be a program that's generally non-responsive for some reason, though it can also happen for other reasons (see below). Windows wait 3 second before muttering "jerk" under its breath and moving on to the next window to ask it the same shortcut question.

The general fix

If this is causing your delay, you can pretty easily find the cause.

  1. Start Windows, then before opening any other programs try a shortcut key. Do you experience a delay? If so, go to step 3.
  2. Launch any other programs you typically run. You should now experience the shortcut key delay. (If not, wait until you are experiencing it later before proceeding.)
  3. One by one, stop each of the programs. After stopping each one, see whether the shortcut delay has gone away. You need to stop not only programs running with actual windows, but also programs that appear only as icons in the taskbar's notification area (aka the "system tray"). You might need to expand the notification area to see all of those icons.

Now that you know your culprit, you get to decide: is that program worth the delay it causes? For example, Adobe Creative Cloud has sometimes caused problems for me, so I just tell it not to run when Windows starts. I can still use Illustrator etc. without it running.

If you can't live without the program, either live with the shortcut key delay or, as "user 99572 is fine" suggests, try a macro program like AutoHotKey.

Windows 10 Specific: Action Center

It seems that Windows 10 has introduced a twist, presumably causing this to happen for more people. (This might happen in Windows 8 too; I skipped from 7 to 10).

In the notification area you may see an icon like this:

enter image description here

This is the Windows Action Center telling you that it has system notifications for you to review. When this icon is in this state, it causes the 3-second shortcut delay (at least for me). The Action Center isn't non-responsive per se—it responds instantly when you click it. But apparently for some reason it doesn't respond to Windows shortcut key queries, causing the 3-second delay.

Click the icon and clear the notifications, then the icon will look like this:

enter image description here

This prevents it from causing the delay.

If a notification comes up repeatedly and you find it unhelpful, right click it and tell Windows to disable notices for that application.

Windows 10 Specific: Store and Calculator

Sometimes the delay happens even after doing all of the above. I've narrowed down the problem to two background processes:

  • Calculator
  • Store

Note that they're background processes: they don't appear as interactive windows, and in fact I haven't run them during the current session. For some reason one or the other just appears as a background process—seemingly at random. It's not clear yet why.

When I use task manager to kill them the shortcut delay goes away.

But...

This 3-second timeout probably doesn't cause every keyboard shortcut delay.

One one of my laptops, whenever Adobe Creative Commons is running in background I sometimes experience a delay lasting as long as 30 seconds before launching an app. That's 10 times the timeout Window uses before giving up on a non-responsive process, so something else must be going on in this case.

share|improve this answer
    
If anyone is a Win10 "insider" you can send this as a feedback via the feedback tool. –  VoidStar Aug 24 at 0:53

The problem might have some to do with how windows finds these shortcuts. Any reasonable person might expect that they store the shortcut data in the registry, the registry resides in ram, and they put everything else in there :-)

Instead the Key shorcuts for .INK and .URL are inside the shortcut itself.

http://i.stack.imgur.com/yBpc5.png

As you can see in the picture , after trying to trace down where it was in the registry (its not), I found the change in the Shortcut own data itself.

There are 2 major locations where this data is scanned from, anywhere in all of the start menu, and via the desktop folder.

When people find that removing some program, or some web program, "fixes" the problem, mabey it has to do with items , or mappings, or some unapproved stuff in the start menu or the desktop?

After realising the method used, it was easy enough to take the advice of using another method other than windows, to do the same things.


The notepad shortcut method used, is going to add microbes of delay also. A shortcut to a text file itself, that will eventually open a notepad, will get to go through a fun process. Find the class bounce around in the registry, find the associated program, open that program, and pass in that parameter.

Most program shortcuts can have quoted whole paths "C:\Windows\Notepad" , instead of using environment variables to eventually locate the program, in the many environment variable paths. . Many programs like to stuff thier program path into the enviroment variable path, they have even broken the "search path" there by making the line to long.

Most Program shortcuts can also have quoted parmeters placed after the quoted program path "d:\documents\todo.txt". this has the computer finding the file direct without searching or guessing, and passing the file to it imediataly. (the quotes only nessisary when there are spaces)

If you want to see speed, try it as "C:\Windows\Notepad" "d:\documents\todo.txt" And cut out the middleman. Create the shortcut for the program instead (notepad), and add a parameter for the txt file into the program shortcut. Ok its like DOS now :-) But faster.

To check the enviroment variables (which is only for specific issues) Go to "System", and in the "System Properties", in "Advanced" bring up the "Enviroment Variables" and look at the mess in the PATH variable.

share|improve this answer

I cannot reproduce your problem and do not remember having it on any of my computers. I do not notice any difference to opening a shortcut by clicking. I have only very few of these shortcuts, though, 2 tops.

  • Is there a software that listens for hotkeys that is installed on all your rigs? Maybe this causes shortcuts to be recognized slowly? It could be any app with global hotkeys. You'd have to manually close them one by one to see if it makes any difference.
  • How many shortcuts do have? 10, 20, 30? If you have many, it could also mean slower reaction time.

To speed things up: You could try using a third party software for managing your shortcuts (like AutoHotkey, PhraseExpress or Clavier+ (all of which are available as aportable app). Hopefully, they will work faster. I am using them anyway and keep them on a flash drive to use on multiple computers.

share|improve this answer
    
Thanks for the answer. I've updated my question with some data. –  cherouvim May 21 '12 at 13:32

I had a delay for 2 seconds, starting Notepad using Ctrl+Alt+N that I use to have as its shortcut key. The solution to get rid of the delay was to disable Akamai Netsession client.

To see if this is your problem, you can open Windows Task Manager, and select the "Netsession_win.exe", rightclik and select "End process tree". (There are two Netsession entries, one of them probabli spawning the other - selecting end process tree kills them both).

Now try your shortcut keys again.

If they are quick and nice now, make the change permanent either by uninstalling Akamai NetSession Interface from Add Remove programs in the control panel, or by disabling it in msconfig (so that it doesn't start automatically).

This is how to disable it by opening msconfig: * Start menu / Run / write "msconfig" / Enter. * Switch to the "Startup" tab. * Uncheck the entry with the name "Akamai Netsession Client".

However I'd uninstall it, and only install it again if it is needed. It's just a download agent that some companies use for downloading their software (I believe Microsoft and Adobe has used it).

This was the location of the akamai program: c:\Users\myname\AppData\Local\Akamai\netsession_win.exe

Hope this will help out.

Best regards, Andreas

share|improve this answer
    
Thanks but I don't have anything Akamai related in my PCs. –  cherouvim Jun 17 '13 at 13:12
1  
It might be some other program on your computer then. I had to go through almost all running services and processes on my computer – stopping the unnecessary ones – one by one, until I found the one (Akamai) that caused the delay. Windows has to "ask" every running process "Will you handle this shortcut key?", and if the process hesitates, and don't answer, it takes a few seconds. I found that explanation here: blogs.msdn.com/b/oldnewthing/archive/2012/05/02/10299709.aspx Reading the page again, it might be processes only – services has no windows. Have a look at startup tab in msconfig –  Andreas Jansson Jun 18 '13 at 6:31

As this does not happen in Safe mode, and as I myself have never encountered such a slow-down, some product that you have installed must be causing the problem.

I suggest using Autoruns to turn off startup programs in bunches, until you narrow it down to the one that is causing it.

You could also examine your installed products using Revo Uninstaller Freeware and uninstall products that you don't need any more or that you don't like. Google carefully for products that you don't know.

I would also suggest, for the future, to install some security suite. There are lots of free antivirus products, as well as free anti-adware, and not having some of them is just asking for trouble, same as not locking your door at night.

I am not suggesting that your computer is infected, but that is one possibility for such a weird behavior, so full-scans using several well-known antivirus products would still be a good idea. See How to Clean An Infected Computer.

share|improve this answer

The reason for this is DDE. I don't know the specific technical details this problem generally boils down to a message queue meltdown.

Some applications are not expecting/able to handle DDE messages on an interrupt basis and so when something they ask for arrives or something is broadcasted to them they don't provide an instant response because they are not waiting on the queue. Things get backed up and everything with a dependency on DDE takes forever. In extreme cases even in command windows sometimes you can see letters you type will be lagged for the same reason.

The only way I know to avoid this problem is to avoid running certain applications over time and by trial and error you will notice when running cause delay. There might be a way to tweak things such as changing timeouts or isolation of DDE broadcast domains or tools to look into DDE but I am clueless on this topic.

share|improve this answer

The culprits for me are the "Movies & TV" and "Photos" app. Once I killed this 2 apps in task manager, my keyboard shortcut launched without the 3 seconds delay. Yes, I have to kill both.

I decided to uninstall both apps since I don't need them. To learn how to uninstall built-in apps, I have followed this page successfully:-

http://www.howtogeek.com/224798/how-to-uninstall-windows-10s-built-in-apps-and-how-to-reinstall-them/

share|improve this answer

If you're on Windows 10, try killing "Application Frame Host" (ApplicationFrameHost.exe). This made the delay disappear on my system.

Note that if you kill this process, it will close any modern apps you have running.

share|improve this answer
    
Welcome to Super User. Can you provide any more detail? What are some possible side-effects of killing this executable? Why is this program creating problems with shortcuts? –  Twisty Aug 24 at 2:45
    
This is the modern app host. If you kill it, you can't run modern apps. Most people don't care about this anyway. It causes a problem because it listens to all possible shortcut registrations for some reason, it didn't do that before Win10. Windows has always seemed to deal with multiple competing shortcut registrations badly... it leads to a delay. Every answer in this thread is related to such competing registrations in one way or another, but Windows 10 introduced ApplicationFrameHost.exe as a new culprit. –  VoidStar Aug 24 at 4:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.