Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Kind of a long shot here, but SU would know better than most... I am trying to install Catalyst on a Mac running OS X 10.4.11 and Perl 5.8.6 (this machine will be a local webserver). To avoid any possible problems, I first installed the XCode dev package for 10.4/10.5. When I try to use CPAN to install Catalyst::Runtime, the install process crashes at:

Writing Makefile for ExtUtils::MakeMaker
Writing MYMETA.yml and MYMETA.json
  --NOT OK
Running Make test
  Can't test without successful make
Running make install
  make had returned bad status, install seems impossible

Thoughts? I joined the Apple club in Snow Leopard, so 10.4 is before my time.


EDIT: On a whim, I decided to try installing the DateTime module. I got the same error.

share|improve this question
    
I have tried installing Catalyst on 10.5. Tried for hours without success since there was faulthy dipendencies and dual packages and so on. Wasted half a day. Take my advice and install it on something else instead. I would definately go for Debian. (Documentation and tutorials is for debian). –  r4. May 21 '12 at 14:16
    
You sould not be using the default Perl that comes with mac. It is old, really. There are ways (several options) that is fairly easy that let's you install Perl 5.12. It is better and more recent. That's according to my experiance is what everyone is doing. –  r4. May 21 '12 at 14:18
    
Why are you installing Catalyst on mac anyway, it is just silly. Go debian! –  r4. May 21 '12 at 14:19
    
Olof, thanks for the input. I would like to install it on something else, and will make the suggestion, but I'm doing a favor for a friend and they don't want to change from OS X. From your comment, am I right to understand that any upgrade of Perl isn't worthwhile for this purpose? –  learner May 21 '12 at 14:32
1  
It's funny. A) I have a small Catalyst app running on Lion, B) I am talking to them about at least Linux, but trying to get them to buy a new <$500 machine and C) for whatever reason, CPAN could not find 'make'. Editing /Users/user/.cpan/CPAN/MyConfig.pm and setting make = /usr/bin/make at least fixed one problem, although Catalyst won't compile. I think I'll push for Linux. Thanks! –  learner May 21 '12 at 16:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.