Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a (crappy) home media server with an onboard NVIDIA MCP77 Gigabit LAN chip (under Ubuntu 10.04 Lucid). This is connected to a Virgin Media SuperHub (VMDG480) which contains a gigabit switch via a 3M CAT6 cable. Previously I had an old Cat5e cable (cheap and presumably not good enough for gigabit) which was resulting in it auto-negotiating to 100mb. This was recently replaced by a decent quality Cat6 cable.

The SuperHub's LED for the port is green, indicating a gigabit connection according to their manual. ethtool also reports the connection as 1000mb Full via autonegotiation. However, when running at 1000mb it won't receive any packets at all. I get destination host unreachable when pinging in either direction (router>server and server>router).

System is fully up to date, latest NVIDIA drivers. The router also has the latest firmware. I've scoured the web and not found any reports of the router having problems with gigabit kit. There's no IPTables on this box.

Steps tried so far:

  • different cable
  • different port on switch
  • static IP

What's my next step in diagnosing the issue?

Any help greatly appreciated!

share|improve this question

migrated from May 21 '12 at 20:49

This question came from our site for system and network administrators.

FYI, Cat6 and Cat5e run at the same speed of 1Gb. Cat6a is the "next step" up, at 10Gb. – Chris S May 21 '12 at 20:48

Try taking the linux interface down then back up via ifconfig, ip link or equivalent.

share|improve this answer
Tried via ifdown eth0 + ifup eth0 several times. Server has been rebooted a couple of times as well to no avail. – Lecce May 21 '12 at 20:46

Try a different switch. I've had trouble over the years with switches that are supposedly 1Gb, but don't like certain chipsets for whatever reason. A few Asante switches worked fine with Macs but would refuse to talk to HP desktops.

I suspect it is probably something simple..

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.