Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

So I got a monitor to use as an external for my MacBook Pro. It is an LG e2340 and I am connecting via HDMI by the way. Anyways, there are some issues I have found and I am wondering if there are any ways to remedy them.

  • In the mid-resolution range (1000horizontal-1600h) green lines appear in the dark areas of the external screen
  • In the high-resolution range(1600h-1900h) it seems like the monitor can't handle it because it is all black and the menu buttons don't work.

I tried to see how it fared in OSX and most of the same things were happening. I tried the 1080p option and it did the blank screen thing. Then I tried 1080i and what do you know it worked. I looked up what the i meant and found that it was interlaced so I went back to windows and looked through the advanced resolution options and found options for 1920x1080 (Interlaced) and it worked.

Things I have noticed though are that the refresh rate is only 30Hz so I can sometimes notice flickering, especially with Windows Glass.

So, after all of that, what do you think is wrong? Is there a way to increase refresh rate with interlaced? Or even better, how can I get 1080p to work?

Thanks a bunch

EDIT: It works with 720p so its not that its not capable of progressive. On the web page here it says Full HD 1080p = YES

share|improve this question
    
What model year is this MacBook Pro? – evan.bovie May 22 '12 at 0:35
    
It is a 2011 15" – adamk33n3r May 22 '12 at 0:38
    
What are you using to connect the MBP to the TV (specifically, what kind of cable and adapter)? Are they Apple branded, or are they generic? – evan.bovie May 22 '12 at 1:01
    
It is a generic mini port to hdmi cable – adamk33n3r May 23 '12 at 1:35
    
Have you tried official Apple adapters or other cables? I'm thinking this is because you have a bum cable that can't sustain high data rates. – evan.bovie May 23 '12 at 1:46
up vote 0 down vote accepted

It's probably a bad cable. Read the above comments for the discussion.

share|improve this answer
    
It was a bad cable – adamk33n3r Jun 5 '12 at 17:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .