Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

my OS is 10.5.7. I have an external hard disk, formatted as mac os extended (journaled), connect to my mac machine through USB cable.

I have used it for a while, but now it not working.

error showed in /var/log/system.log.

USBF: 2521.384 AppleUSBEHCI[0xa515800]::Found a transaction which hasn't moved in 5 seconds on bus 0xfd, timing out! (Addr: 0, EP: 0)

.....

......

kernel[0]: USBF: 2588.616 [0xa6baa00] The IOUSBFamily was not able to enumerate a device.

but luckily, in my work place there is a mac with OS 10.4, so i had plugged the disk to 10.4, it worked!!!

I did checked "System Profile" on both machines (10.5, 10.4). under usb section , for 10.5 it shows USBEHCI, under 10.4, it shows USBOHCI.

I am not a expert on USB Device , can any one tell me why 10.5 cause the problem.

it was worked under 10.5

share|improve this question

migrated from serverfault.com Jul 16 '09 at 0:55

This question came from our site for system and network administrators.

9 Answers 9

  1. Try again with an external powered USB port from a hub.
  2. If you don't have a hub and you are on a desktop, use a port that is on the desktop, not a peripheral. If you're on a laptop, try the two-port adapter described above.
  3. If you are using a CPU port, try a different one.
  4. If still no joy, try a different cable. Even new cables can be defective.
  5. Check the USB port on the external drive. If it is loose, the connection may be good enough for power but not good enough for signal. If so, consider getting a replacement enclosure.
  6. If eliminating the silly mechanical possibilities doesn't work, go on to the other suggestions.
share|improve this answer

What type of mac are you trying it on? I had one friend that had an external closure that worked great on one mac but tried on a different model and it didnt work. They were both running 10.5 and it was determined that the chipset used in the external enclosure just did not like certain macs. That is my experience in dealing with macs and usb external drives.

share|improve this answer
    
max pro 2 x 2.66 Ghz dual - core intel xeon. but the disk worked for a while. –  ctx2002 Jul 15 '09 at 23:27

I actually had that same problem, and I stuck the drive on a USB 2.0 powered hub and it seemed to clear up.

share|improve this answer

The hard disk may have failed or is failing. I'd have to suggest that you do a DFT test on it to ensure it is still functional. Does it work on other computers?

The problem is that I doubt you can run a test like this from the USB port. It may need to be extracted from it's external casing and plugged directly in to a computer.

If you are not comfortable with this, your local Geek Squad should be able to help (for an arm and a leg).

share|improve this answer

Can you see the device in /Volumes?. In Terminal, try running

ls /Volumes

To see if the device is displayed there. I once had a similar problem where a flash drive would not show up in Finder, but it was in /Volumes. Reformatting the drive fixed the problem for me.

share|improve this answer

Have you tried mounting the drive with Disk Utility? I have found a few flash drives wont show up until I go to Disk Utility and find the problem drive right click and choose mount.

share|improve this answer

Well, I reckon its an incompatibility between the chipset in your USB disk and 10.5.

I too had a (powered) enclosure that worked very reliably with 10.3.x on a PowerPC Mac mini, and then became very unreliable as soon as I'd upgraded to 10.5. (I don't believe in coincidental disk failures.)

Short of spending a lot of effort with Apple Support (which I've done previously on other disk-related issues, and still didn't get the problem fixed) I think you'll just have to find another enclosure and swap your disk over.

share|improve this answer

You haven't specified what type of machine you have tried it on (i.e. laptop or desktop) and what type of external USB drive you are having problems with.

I'll assume for now that you are trying to connect a 2.5" USB drive, so it could be the case that the USB port on your mac is unable to provide enough power to the device.

I would recommend trying a different port or using a USB cable that allows you to draw power from 2 USB ports. Something similar to this:

alt text

share|improve this answer

It can be noted that the error messages you are getting are the kernel logging that the USB device and the computer are not talking to each other properly and in my experience has all but once been an issue with a bad cable or hardware failing.

Have you tried another USB port on your computer running 10.5? Or another computer running an earlier version of 10.5? (eg. 10.5.6 or earlier). According to the the user forums at discussions.apple.com there appear to be some odd USB issues in 10.5.7

share|improve this answer
    
super user is not in public yet. i have tried 2 10.5 machines, both has same problem. –  ctx2002 Jul 15 '09 at 23:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.