Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I recently downloaded an ASP.NET project, which was a self-extracting zip file. I right-clicked the file and chose Open With → Microsoft Visual Studio. Now apparently it unzipped and set the default program for all .exe files to Visual Studio.

How can I fix the .exe file extension so it is not associated with Visual Studio?

share|improve this question

marked as duplicate by Canadian Luke, random Jul 29 '14 at 4:17

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

You can fix it by taking a look at this Microsoft page: KB950505.

There is a "Fix it for me" program linked from the page. Alternatively, you can manually follow these directions:

Because you cannot open .exe files normally (this also happens with certain viral infections), you have to use a roundabout way to make the necessary changes.

  1. Open Task Manager (CTRL-ALT-DEL)

  2. Press and hold CTRL and click File - New Task (Run...). This will open a Command window.

  3. Type "notepad" and press Enter. This will open Notepad.

  4. Paste the following text into the Notepad window:

    Windows Registry Editor Version 5.00
    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts.exe\OpenWithProgids] "exefile"=hex(0):

  5. Click File - Save As.... Set the file type to All Files, name the file "fix.reg", and set Encoding to "Unicode". Remember where you've saved it.

  6. In the command window, navigate to where you saved fix.reg and type "reg import fix.reg"

  7. Click Yes and OK to any prompts.

  8. Reboot your computer.

Note: I had issues pasting the specified text for the registry import. If the above text doesn't work, go to the KB article linked above and paste from there.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.