Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to use rpm to install a file through the linux terminal. The file I'm currently trying to install is in my downloads folder and is named: vnc-server.rpm

But when I type rpm -Uvh linux-server.rpm into the terminal, I get: error: open of vnc-server.rpm failed: No such directory or file.

But that file clearly does exist because it's right here. Does it need to be in a specific place for terminal to find it?

Update: I tried using the 'ls' command so find the file directory using it both regularly and with sudo and it could not find the file. But somehow, moving it out of my downloads folder immediately fixed the issue.

Now I was able to try to install the file, but it still failed because I'm missing a bunch of dependencies.

share|improve this question
    
Write a small part of the file name and press <Tab>, and the terminal will auto-complete the file name for you. This takes care of spelling errors and such. In this case you say the file is named linux-server but the error message clearly indicates that you ran the command with the argument vnc-server (it is probable that your problem description of linux-server is a typo, though). –  Daniel Andersson May 22 '12 at 16:06
    
Yeah, it was a typo, on my computer both the file and my attempts used the name vnc-server.rpm –  Mark Kramer May 22 '12 at 16:07
    
Also, pressing <Tab> doesn't seem to do anything. –  Mark Kramer May 22 '12 at 16:08
1  
The file has to be in the current directory of your terminal session. Do you know about this and cd? Are you sure that you give the correct path to the file? Try the command ls with your file name as argument. Can ls find it? If not, the problem is not related to rpm in any way. –  Daniel Andersson May 22 '12 at 16:11

2 Answers 2

up vote 1 down vote accepted

No unless for some reason the permissions on your download folder have changed, which would require you to preface your command with sudo.

See if this fixes your problem: http://www.cyberciti.biz/tips/rpm-command-no-such-file-directory-error.html

share|improve this answer
    
I was not able to find it using the ls command. So I moved it out of the downloads folder to see if that would make a difference and it worked. –  Mark Kramer May 22 '12 at 16:16

Could it be possible that you are not currently in the Downloads folder (or wherever the desired file is located)? Try typing pwd command in the terminal and see which path it returns. If it is not the same path as the file then it's not that weird.

Alternatively you can check the files that are in the working directory with ls -l command, and try to see if the file is listed there.

If the auto-complete doesnt work then it's most likely that you are not in the right working directory, try to use the cd command to change the working directory to where the file is located.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.