Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Background: I am trying to connect my MacBook Pro to a business grade network where I do not have access to reboot the server, switches, or router.

Problem: The MacBook Pro (running Snow Leopard upgraded from Leopard) will not obtain an IP address via DHCP and repeatedly self-assigns a 169.xx IP address. I have tried restarting the computer, changing network ports and using different cables. Each time the computer has the same issue. I am able to connect to the same network via a wireless access point with no issue and other PCs (new to the network) are able to obtain an IP address without issue.

Question: Why won't my MacBook Pro obtain an IP address via the ethernet connection? Any suggestions?

share|improve this question
To be sure the ethernet port on the MBP isn't hosed - are you able to get an IP on other networks (eg. your home network) – Chealion Sep 17 '09 at 17:01
I just set up a test network with a TFTPd DHCP server setup. Then connected the MacBook to my Lenovo x200 via a 10/100/1000 switch and activated the DHCP server (TFTPd). I then manually requested an IP address from the MacBook and saw the request show up on the Lenovo; however, no IP address was assigned on the Mac (the Lenovo said it had assigned to the Mac). – BlueDevil Sep 17 '09 at 17:10
So, by today did you get a solution for this? I'm having a similar issue where my mac sometimes won't get DHCP correctly, in two different networks. Anything else works fine, and static IP also makes the mac work. – cregox Apr 23 '10 at 20:40

10 Answers 10

up vote 1 down vote accepted

If you're running a Snow Leopard Server, you'll need to go to Server Preferences and disable the security firewall so that the computer can access the DHCP on the router. Once that happens, you'll be assigned the correct IP address.

This took me several days and hours to figure this out. It's so frustrating since I don't know if this security feature is overkill if you're behind a NAT router.

share|improve this answer

Does that business even use DHCP? If it is a "business grade" network, they may have specific network settings, MAC authentication, or other security measures along with DHCP. They do this to keep their machines on the network and others off of it. I assume you are authorized to use this network? You may have to obtain permission to add/use another computer on thier network.

share|improve this answer
Good point -- BlueDevil, you said you upgraded from Leopard. Was this laptop working on this wired network before the upgrade? – Doug Harris Sep 17 '09 at 16:28
Yes, they use DHCP with no other specific network settings. I have tried several other computers not native to the network and they all obtain IP addresses without issue including Linux and Windows OSs running in VMs. – BlueDevil Sep 17 '09 at 16:28
Yes. The laptop had no issues previous to the upgrade. – BlueDevil Sep 17 '09 at 16:29
Does the MBP connect to other DHCP networks just fine or is this one the only problem? – Troggy Sep 17 '09 at 16:31
Hmm, after reading your comment above, I am starting to wonder if the drivers or something isn't working right on the OS end. You might have to reinstall SL if you have no luck with anything else. Does the wireless connectivity connect to things ok? – Troggy Sep 17 '09 at 17:39

Obvious answer: Have you confirmed that the ethernet port is configured to get IP address via DHCP?

If DHCP is already set for this network inteface, go to the "advanced..." window and click "Renew DHCP Lease". Does this help?

Ugly hack workaround: Delete the ethernet network interface (select it and click the "-" button at the bottom). Create a new ethernet network interface.

share|improve this answer
I have already tried all of these solutions including restarting the computer, deleting the ethernet connection, and manually renewing the IP address. The laptop is still self-assigning IPs. Thanks for the suggestions. – BlueDevil Sep 17 '09 at 16:31

Have you tried repairing disk permissions and repairing the disk via disk utility from a bootable OS cd? A lot of times flakey permissions can cause all kinds of weird problems, especially after an upgrade.

share|improve this answer

By running the following command on the MAC while attempting to DHCP one may provide more information (possibly than desired)

sudo tcpdump -vv -ien0 port 67 and port 68
share|improve this answer
Probably not going to solve the problem because the test DHCP server shows assignment (2nd comment in question). – benc Dec 21 '09 at 18:30

On my unibody MacBook Pro 17" running Snow Leopard, the DHCP problem turned out to be fixed by switching from WEP to WPA2 security on the WiFi network. I had no problem using it with WEP on an iPad, two iPhones, and another MacBook Pro (unibody 13"). In fact, both MBP's are running 10.6.8 so I'm still not sure why one worked and one didn't, but after switching to WPA2 everybody's happy!

share|improve this answer

I had the same issue after upgrading from Leopard to Snow Leopard. Upgrading SL from 10.6 to 10.6.1 resolved it for me, but YMMV

share|improve this answer

My answer to this other question (for Wifi, but still applicable to your issue) will clear out your network preferences, which will be much easier than reinstalling the OS.

When I wrote that 10.6.2 wasn't out, but again reinstalling the 10.6.2 combo updater would be a great step to take before an OS reinstall.

share|improve this answer

We had a similar problem on our office network after we upgraded the DHCP (Debian Linux) host. Turned out the default /etc/hosts file on that box had a wrong entry for its own IP: ns

This IP was returned in the BOOTP/DHCP request, and Mac clients refuse this reply! Changing the IP: ns

and restarting dhcpd3 fixed the problem :-)

share|improve this answer

If you're running ipfw, then add this line:

allow udp from 67,68 to any 67,68 in keep-state
share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .