Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm doing some research on 'cribbage' an Ubuntu 10.04 box which connects to 'prodcsamba01' via CIFS:

cribbage $ mount | grep prep
//prodcsamba01/prepfsnr on /prep type cifs (rw,mand,noexec,nosuid,nodev)

prodcsamba01 in turn has '/prepfsnr' mounted from the server 'prepfsnr01'.

In the course of my research, I ran file on the file 0522_3600001.raw.gz:

cribbage $ file /prep/ftphome/archive/raw/0522_3600001.raw.gz    /prep/ftphome/archive/raw/0522_3600001.raw.gz: gzip compressed data, was "0520_2460001.raw", from Unix, last modified: Sun May 20 08:16:53 2012 

Note that the filename inside the zip file is supposedly "0520_2460001.raw", even though the file name is 0522_3600001.raw.gz.

At this point, I logged in to ftpproc, which has the directory that cribbage sees as /prep mounted as /prepfsnr/prep. The mount is via NFS.

I ran file on the same file, and I get different results:

ftpproc $ file /prepfsnr/prep/ftphome/archive/raw/0522_3600001.raw.gz
/prepfsnr/prep/ftphome/archive/raw/0522_3600001.raw.gz: gzip compressed data, was "0522_3600001.raw", from Unix, last modified: Tue May 22 09:18:51 2012     Tue May 22 11:23:50 

md5sum is also different between CIFS and NFS:

ftpproc $ md5sum /prepfsnr/prep/ftphome/archive/raw/0522_3600001.raw.gz
a722fb54448a2fea752461c2edadbded  /prepfsnr/prep/ftphome/archive/raw/0522_3600001.raw.gz

cribbage $ md5sum /prep/ftphome/archive/raw/0522_3600001.raw.gz
a745dbf6c741d698839e4a9c2166f821  /prep/ftphome/archive/raw/0522_3600001.raw.gz

What could cause this?

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

For performance reasons, CIFS allows clients to get exclusive access to a file, in which case they can locally make changes that are not immediately sent to the server.

Is there perhaps an application that still has an exclusive lock on this file? The smbstatus command (on the server) should be able to tell you.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.