Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When trying to uninstall Microsoft Security Essentials on Windows Vista x86 via Programs and Features, I got an error message, code 8007066F, with no description. How can I remove Security Essentials?

share|improve this question
up vote 0 down vote accepted

Microsoft published a Fixit tool for this at KB 2435760. After running this, Security Essentials was removed, but I still needed to remove the executable from the startup list. I did this by going to Start-> type in MSCONFIG and pressing Enter. Once the MSConfig tool started, I clicked on Startup, and unticked 'Microsoft Security Essentials' from the list.

There is this Microsoft Fix It if the above link does not resolve the issue.

share|improve this answer

The above links didn't work for me, but the response here by GlenDelport worked.

From the URL (with minor modifications):

  • Browse to C:\Program Files\Microsoft Security Client\
  • Locate the file Setup.exe, right click on it and choose properties
  • Click on the Compatibility tab
  • At the bottom of the tab click 'Change Settings for all users'
  • On the next screen check the box for 'Run this program in compatibility mode for:' and choose Windows 7
  • Click OK
  • Click OK
  • From the taskbar search box type cmd.exe and right click and choose 'Run As Administrator'. This will open an elevated command prompt as Administrator
  • In the command prompt window copy/paste or type the following:

    cd C:\Program Files\Microsoft Security Client
    setup.exe /x /disableoslimit
    
  • Choose to Uninstall

  • Once this has finished, reboot and Microsoft Security Essentials will be gone and Windows Defender should be running correctly.
share|improve this answer
    
This post was for Windows Vista... – Canadian Luke Jun 14 at 5:18
    
Oops. Well, I figure I'll leave this here for now in case anyone has this issue on Windows 10 and receives the 0x8004ff6f error. I'm not sure why I ran into this post and didn't realize it. I'll try to make a different question and delete this post later. – Achal Dave Jun 14 at 7:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.