Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This has been bugging me for sometime and I really need to learn why I am having this problem.

I have verizon fios and an ActionTech router (http://www.actiontec.com/products/product.php?pid=189)

I recently purchased a Linksys RVS4000 router (http://www.cisco.com/en/US/products/ps9928/index.html)

I purchased the LinkSys because I want to be able to transfer files are a quicker rate (gigabit).

Here is my configuration:

Actiontech: 192.168.1.1 Linksys: 192.168.0.1

My desktop and all other devices are on the Linksys and are able to see other. My laptop is on the actiontech router because its wireless.

I am trying to get my desktop to be able to access my laptop (via share) but it can't find the computer and vice-versa.

Is there a particular way I need to set this up?

I have the Linksys setup as a gateway.

I want to apologize if I am very vague or left out any important details.

Thank you!

share|improve this question
    
I believe you have to open the ethernet masks to share beyond the Lnksys . Change masks from 255.255.255.0 to 255.255.0.0 which permits LANS from 192.168.0.x to 192.168.255.x to reach each other. –  Tony Stewart May 23 '12 at 0:42
    
Is this a setting in the router? –  gdx May 23 '12 at 0:51
add comment

2 Answers

up vote 1 down vote accepted

It appears you have purchased a router, when what you wanted (for fast local file transfers) was a switch.

The Linksys has a gigabit switch built in, so you can use that, but all of its routing capability is effectively redundant.

The first thing to do is to disable DHCP on the Linksys, and give it a static IP address on its LAN interface that is in the 192.168.1.0/24 range. You'll want this to be outside of the DHCP range that is used on the actiontech to avoid it giving the same address out to PCs. Disable the WAN interface.

Then plug one of the LAN ports on the linksys to the LAN port of the Actiontech.

And thats it. Effectively you are connecting the switch on the Actiontech to the switch on the Linksys, so they are in the same broadcast domain. Therefore anything connected to the Linksys broadcasting for a DHCP address will be responded to by the Actiontech. So they will get their IP from there, in the same way that your laptop does. All your devices will be on the same network.

Having said all this, I would return the router and instead purchase a simple unmanaged switch.

share|improve this answer
add comment

I was able to figure it out!

http://www.techsupportforum.com/forums/f136/2-routers-on-the-same-network-163412.html

share|improve this answer
    
That'll work too.. They charge more for crossover cables since made in smaler volumes. :( –  Tony Stewart May 23 '12 at 1:17
    
You don't actually need a crossover. Almost every modern piece of equipment has auto-MDI/X. –  David Schwartz May 23 '12 at 2:06
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.