Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Every time I open iTunes I get the the following warning:

Do you want the application "iTunes.app" to accept incoming network connections?

Clicking Deny may limit the application's behavior. This setting can be changed in the Firewall pane of Security preferences.

warning box

I always click "Allow" but it still pops up.

I set the OS X firewall to allow incoming connections for iTunes.

Any suggestions on how to fix this?

share|improve this question
    
@Spiff, any chance you know if folks having trouble with iTunes 10 have replaced the application icon? –  Arjan Sep 6 '10 at 5:48
    
@Arjan I ran into this problem with iTunes 10 and I had not replaced the application icon. I hadn't tweaked the iTunes.app bundle at all. I'm guessing it was an installer error. I don't recall the exact names of the extra files I had to delete, but I believe they were .nib 's and .xib 's. –  Spiff Sep 6 '10 at 6:57
1  
At Mac OS X Hints someone writes changing the iTunes icon gets one into trouble as well. (That is: when changing it in the application bundle itself; changing it the normal way might not affect the signature, but I'm not sure.) –  Arjan Sep 7 '10 at 17:22
add comment

7 Answers 7

up vote 17 down vote accepted

It's probably easiest to reinstall iTunes.

If the firewall does not remember your choice, then the digital signature (Code Signing) of iTunes is broken. By default, the OS X firewall accepts any software that was signed by Apple without even asking you. So: it should not have asked you. And once asked, it should be able to remember, based on the digital signature. A broken signature (for example caused by changing the contents of the iTunes.app package) will prevent all this.

(Did you by any chance manually change the iTunes icon the application somehow? Or did you install some plugins?)

You can validate the signature of your iTunes by copying the first line and paste it in Terminal:

codesign -vvv /Applications/iTunes.app/

/Applications/iTunes.app/: valid on disk
/Applications/iTunes.app/: satisfies its Designated Requirement

(More details at If Mac code signing is tampered with, what might fail?)

share|improve this answer
    
reinstalling seems to work, thanks. –  cust0s Sep 17 '09 at 17:36
add comment

If you see

$ codesign -vvv /Applications/iTunes.app/
/Applications/iTunes.app/: a sealed resource is missing or invalid
/Applications/iTunes.app/Contents/Resources/English.lproj/iTunesDJSettings.nib/objects.xib: resource added

just delete the files that say "resource added" and verify against codesign again. Once it validates iTunes.app should not popup any more message.

If you wish to resign the thing yourself you can create a signing identity from http://developer.apple.com/mac/library/documentation/Security/Conceptual/CodeSigningGuide/Procedures/Procedures.html

However, I don't recommend it for iTunes, though I used it for other apps.

share|improve this answer
    
I used this approach to fix a longstanding issue I've had with xTorrent. I just deleted the reported files as specified, and codesign then reported success any xtorrent stopped popping up the dialog. /Applications/Xtorrent.app/: a sealed resource is missing or invalid /Applications/Xtorrent.app/Contents/Resources/.CoreStrings.Encoded: resource added /Applications/Xtorrent.app/Contents/Resources/.CoreStringsA.Encoded: resource added –  emmby Jan 26 '11 at 23:42
    
add comment

If reinstalling worked then fine, but I just wanted to mention that in my experience if firewall Deny/Allow settings don't seem to stick it's because you're setting them in a non-admin account. I think in that case they then only stick for as long as you're logged in.

Perhaps reinstalling seemed to work because you then started iTunes in an admin account?

Just a thought.

share|improve this answer
    
Hmmm, good point. Though, for Apple software, the signature should be there right after installation; the firewall does not need to add a signature itself. And can one change firewall settings without entering an admin password? (Too bad I posted the example command line after the question asker had re-installed iTunes. If anyone comes to this question at some later time: please run the codesign command and post your results here.) –  Arjan Sep 17 '09 at 21:35
    
I run as a non-admin user, and when I click allow or disallow I am asked for my administrator username/password to make modifications to the firewall. If you don't give an admin username or password you effectively block the program from getting outside connections. –  X-Istence Sep 27 '09 at 16:48
add comment

Just wanted to report that I faced a similar problem after updating iTunes with the Apple Updater and the solution suggested here worked. Go into the iTunes package and delete all of the files that this terminal command flags as a "resource added":

$ codesign -vvv /Applications/iTunes.app/

When you rerun the terminal command, it will indicate that iTunes.app now "satisfies its Designated Requirement" and the annoying popup should go away.

Note that I don't have any deep understand of why any of this works. Seems like Apple broke something minor in their last software update and the firewall noticed. For any power-Googlers with little experience in these things, make sure you always backup your files before mucking about with anything like this--for your work, those preferences might be important.

share|improve this answer
    
Hurrah. This was exactly what I needed to do - it seems that an older copy of the iTunesHelper.app was left in the resource area and the newer versions of iTunes have the binary in the right place. Deleting these files makes iTunes happy again. Thank you! –  Paul Hargreaves Oct 12 '11 at 15:10
    
add comment

An easier approach if you want to avoid messing with the terminal, modifying packages or resigning apps is as follows:

  1. Download the iTunes installer (http://www.apple.com/itunes/download/).

  2. Move your current copy of the iTunes app from the Applications folder into the trash (but don't touch your preferences or other iTunes folders).

  3. Install a fresh copy of iTunes from the .dmg file you downloaded.

  4. Launch the fresh copy and see that everything is in place with no more annoying popups!

It's important to move the old app to the trash before you reinstall iTunes; if not, the offending files in the package do not get removed. Once you've confirmed this worked, go ahead and empty the trash.

share|improve this answer
add comment

I had this in iTunes 9.0 on Snow Leopard. It went away when I upgraded to 9.0.1. (Probably because of the reinstall, as that worked for you.)

share|improve this answer
add comment

Sometimes it's not related to a codesign or signature validation as much as you're simply using Home Sharing in your iTunes which prompts you if you want to allow incoming connections.

share|improve this answer
add comment

protected by Diago Sep 25 '10 at 11:04

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.