Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a document in Word 2007 that seems to be read only. There are forms in the document that I can type in, but I can't edit or reformat the rest of the document. There is probably a setting somewhere I can flip to make it editable again but I can't find it for the life of me.

FOLLOW UP:

The "Protect Document" button only had "Unrestricted Access" checked, this was one of the first things I checked. However, when I tried checking "Restrict Formatting and Editing" it brought up the Restrict Formatting and Editing sidebar, which stated:

This document is protected from unintentional editing. You may only fill in forms in this region.

With a stop protection button on the bottom, which of course solved the problem. I think that menu item just has a bad name, it should be "Restrict Formatting and Editing Options or Settings"

share|improve this question

6 Answers 6

up vote 4 down vote accepted

Is the file "protected"? If so, go into the protect/unprotect section and unprotect the file. Then you should be able to edit any part.

If you have the developer tab enabled, there is a quick section in there to change the restrictions or protections.

To enable developer tab: Go to the big main Word menu (the big bubble in upper left), click the "Word Options" at the bottom, the default page will be the "popular" options, check the "Show Developer tab in the Ribbon".

share|improve this answer

Copied from Unprotect a Word Document so please vote him up over there.

One possible solution. I think there are others as well.

  1. Open a protected document in MS Word
  2. Save as "Web Page (*.htm; *.html)", close Word
  3. Open html-document in any Text-Editor
  4. Search <w:UnprotectPassword> tag, the line reads something like that: <w:UnprotectPassword>ABCDEF01</w:UnprotectPassword> (password is already in hex-format)
  5. Keep the "password" in mind
  6. Open original document (.doc) with any hex-editor
  7. Search for hex-values of the password, which is stored in reverse order. (e.g. If password is 0xAB 0xCD 0xEF 0x01. Then the password is in the .doc file as 0x01 0xEF 0xCD 0xAB)
  8. Overwrite all 4 double-bytes with 0x00, Save, Close
  9. Open document with MS Word, Select "Tools / Unprotect Document" (password is blank)
share|improve this answer

This solution works if you can open the file but are prevented from editing or overcoming the preset form fields in a *.docx Word Document.

To unprotect a Word *.docx document that has been protected for forms or editing:


  • Make a copy of the file and rename it to have a .zip extension (mydoc.docx.zip).

  • Extract the contents of the new ZIP file to an empty folder (e.g. "My Documents\newdoc").

  • Locate the file "My Documents\newdoc\word\settings.xml" and open it in Notepad or your favorite text editor.

  • Find and delete the XML tag beginning with <w:documentProtection and ending with the next occurence of >.

  • Also, check the beginning characters of this file. The first line MUST begin with the following:

    <?xml version="1.0" encoding="UTF-8" standalone="yes" ?>
    

    There must be no additional characters or spaces in front of it, nor a blank line above it. Some text editors will add characters or extra lines to some XML files, depending on character encoding. Delete any extra lines or characters at the beginning of the file.

  • Save the settings.xml file.

  • Here's the tricky part - put the files back into a new ZIP file, making sure to include the associated directory structure. You'll be zipping the contents of the new directory (\newdoc) into a new ZIP file (unprot.zip).

    • Rename the new ZIP file to a .docx extension (unprot.zip.docx).

    • Open the new, unprotected .docx with Word.

share|improve this answer
    
Hah! brilliant, exactly what I was after :) –  Zevran Jun 4 at 6:21

here's what i did.. in my case, i can open the file, but i can't select nor copy nor highlights everything, it just keeps me going back to the header. hope this steps help:

  1. open the document in word then save it as web page (.htm)
  2. open the .htm file using notepad
  3. press ctrl + f, to find this:

    w:documentProtection>xxxxx < /w:documentProtection>

  4. once you see the above code.. highlight it and delete it
  5. save it as .xml
  6. open the .xml file using Microsoft word
  7. save it as .doc
  8. open the .doc file using the Microsoft Word.
  9. tada!!!! by then, you should be able to edit the document :)

share|improve this answer
    
cf. opensourcehacker.com/2011/09/23/… for more details. –  Russell S. Pierce Apr 10 at 14:21

in the protected file do the following keyboard shortcuts!

Ctrl+A
Ctrl+C

Ctrl+N # to open a new file
Ctrl+V # in new file
Ctrl+S # save

and you have a file without protection with all formatings.

share|improve this answer

I was having the similar problem, not being able to edit/copy documents.

Just open the document, save as ODT (open document text), and while saving rename the file. It will tell you that you will loose some data, just OK it.

After that open your ODT file. You will find all the edit/copy/paste options in it. Now you can copy & paste the file data in new doc. file.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.