Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I need to configure 857W as PPTP client. PPTP is officialy not supported (there is no such protocol in request-dialin group) but it could be enabled with "service internal". Any way, my questions are not pptp-specific, I believe.

I do the following: 1) Enable vpdn 2) Create vpdn group with request-dialin configuration and initiate-to my VPN server

BTW, can I set domain name here instead of ip?

3) Configure it as pool-member 1

4) configure my dialer 0 interface to: dialer vpdn, dialer-group 1, dialer pool 1, dialer persistent.

What is the diffrerence between dialer pool and dialer in-band? Dialer pool allows On-demand dialing? But if it persistent is not it the same thing? Anyway, I want my cisco to always connect to VPN regardless interesting traffic.

I also set enc ppp and ppp chap .

My VPN server uses ms-chap-v2, how can i configure cisco to send appropriate login and password? Can "ppp chap" be used? Or I should use "username"?

After all I see debug:

*Mar 22 22:47:02.291: Di0 DDR: Nailing up the Dialer profile [attempt 540] *Mar 22 22:47:02.291: Di0 DDR: Dialer dialing - persistent dialer profile *Mar 22 22:47:02.291: Vi2 DDR: Dialing cause Persistent Dialer Profile *Mar 22 22:47:02.291: Vi2 DDR: Attempting to dial 2672676772 *Mar 22 22:47:02.291: Vi2 DDR: Unable to dial 2672676772. *Mar 22 22:47:02.291: Vi2 PPP: Phase is DOWN, Setup

As I can see here cisco tries to set up my di 0, that causes it to set up Virtual interface and to "dial" to my server, but dialing failed for some reason. Even PPP failed to start.

But I do not see any vpdn calling debug which is enabled!

What debug info should I enable to understand what has happened? Is persistent dialer could be used with vpdn?

Thanks.

share|improve this question

1 Answer 1

The "service internal" command is nessesary as pptp has been deprecated by Cisco, and thus hidden the CLI command "protocol pptp" under vpdn.

First - using "service internal" is required to att pptp as the protocol for your vpdn group. Output attached:


Router(config-vpdn-req-in)#service internal
Router(config)#vpdn-group pptp    
Router(config-vpdn)#request-dialin  

Router(config-vpdn-req-in)#protocol ?      
  l2f   Use L2F
  l2tp  Use L2TP
  pptp  Use PPTP

Dial and vpdn configurations, their structure and syntax, is not something I'll plunge into here. It's old, not always logical and the reuse of dialer interface for vpdn sometimes confusing. CCO is full of ancient scriptures to study on this topic.

A working config attached. The dialer string is just pro-forma.

!
vpdn-group pptp
 request-dialin
  protocol pptp
  pool-member 1
 initiate-to ip 11.22.33.44
!
interface Dialer0
 ip address negotiated
 encapsulation ppp
 dialer pool 1
 dialer remote-name pptp-lac
 dialer string 1234
 dialer vpdn
 dialer-group 1
 no cdp enable
 ppp chap hostname 857W
 ppp chap password 7 020E0D7206320A325847071E5F5E
!
ip route 0.0.0.0 255.255.255.255 Dialer0
!
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.