Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a pesky problem that I can't solve without some help: I had Leopard 10.5.8 installed on a Mac Pro and Xcode 3.1.3 and yesterday I upgraded to SL. After the upgrade, something happened to the existing Xcode because I couldn't build anymore (xcodebuild could not be found by my build tools).

So I installed Xcode 3.1.3 again thinking that a refresh would fix the problem. It didn't and I ended up with 2 Xcode apps - one in /Developer/Applications and one in /Xcode 3.1.3/Applications (when I reinstalled Xcode it wanted to install in /Xcode 3.1.3, and there wasn't an option to install in the default location -/Developer).

Next step was to delete both /Developer and /Xcode 3.1.3 and reinstall Xcode 3.1.3. Again it wanted to install in /Xcode 3.1.3 and it still didn't work. Fine, I said, I'm tired of fiddling with this, I'm installing Xcode 3.2. Which I did and it installed in /Developer.

Now I can build using Xcode 3.2 but I can't debug from Xcode. When I launch a debug session I get this message in the GDB console: "Exception: starting task (/Developer/usr/bin/gdb) ; name: NSInvalidArgumetException, reason: working directory doesn't exist."

If I invoke gdb from a terminal prompt it works fine. Any suggestions on how to fix this?

share|improve this question
up vote 3 down vote accepted

xcode 3.1.3 won't work with SL, you need 3.2, which comes with the DVD. that much you've figured out already (but honestly, something similar happened to me; can't the SL installer see that xcode is installed and suggest to me to install 3.2??).

i don't know exactly what happened to your setup, but i would guess that the uninstall/reinstall of 3.1.3 on an OS with which it's not supposed to play nice with has messed something up.

i would suggest trying:

sudo /Developer/Library/uninstall-devtools --mode=all

which will cleanly remove all xcode, and then reinstall xcode 3.2 (again), and seeing if the problem goes away.

share|improve this answer

I dont know what version it is, but there is a new xcode supplied with snowleopard which should fix your problem.

share|improve this answer
1  
That's Xcode 3.2. – Chealion Sep 18 '09 at 15:06

I hit this too, and uninstalling didn't work, but deleting the XCode preferences files did.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .