Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I was looking for a convenient way to keep links to web sites between multiple computers on Monday. After a bit of searching, I found out Google offers a service that covers my desires just fine, Google Bookmarks.

Fast forward to today, Wednesday afternoon, I loaded up Google Bookmarks to find this:

My Google "Favoritos"

Sorry, I don't speak Portuguese. I cacheless-refreshed my gmail tab to make sure something wasn't up with my whole account, and it's fine. Hitting the translate button works...

My Google "Favorites"

...sort of. It works enough to at least know what's going on. I can work with this, but... It really seems backwards.

How do I tell Google I don't understand Portuguese in my Bookmarks?

share|improve this question
    
Are you using a proxy or VPN? What is your current geoIP location? –  iglvzx May 23 '12 at 19:42
    
@iglvzx That site says I am in Akron, Ohio, United States. I also am not (knowingly) using a proxy. –  Aeo May 23 '12 at 19:48
2  
I've just experienced this with an English website that it thought was in Czech. Perhaps Chrome is broken. –  user3463 May 23 '12 at 19:52
    
@ekaj This didn't take place on a mobile connection. Was a cable internet connection. –  Aeo May 24 '12 at 7:20
    
Would be helpful if that was stated in the question. –  ekaj May 24 '12 at 16:19

3 Answers 3

up vote 4 down vote accepted

You set your default language across all Google products from your Google account. To do this, navigate to your Google account page.

Google Account Page

You should get a page similar to the above page. Now, just click on the language tab and you should be presented with a list of your preferred languages in their respective order.

Google Account - Language Page

Just set your primary language to the one you prefer. You can also add other languages in case your primary language isn't available for a Google product.

share|improve this answer

This has happened to me as well. I think there is a bug on Google's side. I am a heavy Google Bookmarks user and on two different occasions Google Bookmarks decided to open the Russian version instead of the English one.

And this although

  • all settings in all Google products are set to English,
  • no proxy is used,
  • I do not live in Russia, I do not speak Russian and I have never been to Russia or used Russian sites.
share|improve this answer

Try visiting https://www.google.com/bookmarks/?hl=en ? Adding hl=?? to Google's URLs will solve the language problems in many cases.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.