Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My folks have a Windows XP system (fully patched) that recently stopped communicating with the local router.

Wired connectivity is as follows: Computer >> Router (Netgear WGR614v6) >> DSL Modem >> Internet

When they start up the computer, they (eventually) get a message that there is limited or no connectivity. The route shows positive link lights for everything.

So far, we've tried the following:

  • Replacing cable between the computer and router lan port.
  • Plug cable between the computer and router into a different lan port on the router.
  • Replace router with an identical router with similar configurations.
  • Releasing and renewing IP addresses (which returns an error about failing to communicate with DHCP server).
  • Connecting DSL modem directly to router (same issue about limited connectivity).
  • Specifying a static IP (which still prevents us from pinging the router).
  • Changing speed/duplex on NIC from autonegotiate to 10 Mbps/HD.
  • Disabling/enabling NIC.

Unfortunately, they don't have a secondary computer so I'm not able to easily confirm the computer as the cause of the issue. At this point though, it seems likely. Can someone please advise on what else we can do to troubleshoot here?

share|improve this question

2 Answers 2

You could try resetting the TCP/IP stack.

From the above link: Open a CMD windows (run>cmd), type: netsh int ip reset c:\resetlog.txt and then reboot your PC

There is also an MS Fixit link in the KB if you don't feel comfortable doing it or walking or parents through it.

share|improve this answer
    
This is a great idea. Thank you. I'll try this out. –  Mike B May 23 '12 at 22:05
    
Thanks for the suggestion. We tried this and it didn't seem to work. At this point I'm wondering if the driver is corrupt or if there is malfunctioning hardware –  Mike B May 24 '12 at 17:47
1  
I would suggest acquiring another PC or NIC. PCI NIC's can be had for next to nothing. –  Kyle May 24 '12 at 17:49
    
Good idea. Thanks. –  Mike B May 24 '12 at 18:03

Boot a Linux live CD/DVD (e.g. Knoppix) to see if it is working there. If it is, you likely have a software problem. Otherwise a hardware fault has to be assumed.

share|improve this answer
    
Great idea. Thanks, I'll give this a shot. –  Mike B May 23 '12 at 22:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.