Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I used network-manager-pptp under Ubuntu 12.04 to configure the vpn.

IPv4 Settings: 
Automatic

VPN: 
Gateway - set
User name - set
Password - Always Ask

PPTP Advanced Option:
PAP, CHAP, MSCHAP, EAP - unchecked
MSCHAPv2 - checked
Use Point-to Point encryption (MPPE) - checked
Securtity - 128-bit

all other settings are unchecked

But always I get the same message when I try to connect to the vpn: connection failed. The same issues was on the Ubuntu 10.04. In the sys log I have:

<info> VPN service 'pptp' started (org.freedesktop.NetworkManager.pptp), PID 3042
May 23 22:17:42 NR5 NetworkManager[983]: <info> VPN service 'pptp' appeared; activating connections
May 23 22:17:42 NR5 NetworkManager[983]: <info> VPN plugin state changed: init (1)
May 23 22:17:42 NR5 NetworkManager[983]: <info> VPN plugin state changed: starting (3)
May 23 22:17:42 NR5 NetworkManager[983]: <info> VPN connection 'VPN NAME' (Connect) reply received.
May 24 00:21:00 NR5 pppd[9773]: Plugin /usr/lib/pppd/2.4.5/nm-pptp-pppd-plugin.so loaded.
May 24 00:21:00 NR5 pppd[9773]: pppd 2.4.5 started by root, uid 0
May 24 00:21:00 NR5 pppd[9773]: Using interface ppp0
May 24 00:21:00 NR5 pppd[9773]: Connect: ppp0 <--> /dev/pts/3
May 24 00:21:00 NR5 pptp[9776]: nm-pptp-service-9764 log[main:pptp.c:314]: The synchronous pptp option is NOT activated
May 23 22:17:42 NR5 NetworkManager[983]:    SCPlugin-Ifupdown: devices added (path: /sys/devices/virtual/net/ppp0, iface: ppp0)
May 23 22:17:42 NR5 NetworkManager[983]:    SCPlugin-Ifupdown: device added (path: /sys/devices/virtual/net/ppp0, iface: ppp0): no ifupdown configuration found.
May 24 00:21:01 NR5 pptp[9786]: nm-pptp-service-9764 log[ctrlp_rep:pptp_ctrl.c:251]: Sent control packet type is 1 'Start-Control-Connection-Request'
May 24 00:21:01 NR5 pptp[9786]: nm-pptp-service-9764 log[ctrlp_disp:pptp_ctrl.c:739]: Received Start Control Connection Reply
May 24 00:21:01 NR5 pptp[9786]: nm-pptp-service-9764 log[ctrlp_disp:pptp_ctrl.c:773]: Client connection established.
May 24 00:21:02 NR5 pptp[9786]: nm-pptp-service-9764 log[ctrlp_rep:pptp_ctrl.c:251]: Sent control packet type is 7 'Outgoing-Call-Request'
May 24 00:21:02 NR5 pptp[9786]: nm-pptp-service-9764 log[ctrlp_disp:pptp_ctrl.c:858]: Received Outgoing Call Reply.
May 24 00:21:02 NR5 pptp[9786]: nm-pptp-service-9764 log[ctrlp_disp:pptp_ctrl.c:897]: Outgoing call established (call ID 0, peer's call ID 32930).
May 24 00:21:31 NR5 pppd[9773]: LCP: timeout sending Config-Requests
May 24 00:21:31 NR5 pppd[9773]: Connection terminated.
May 23 22:18:13 NR5 NetworkManager[983]: <warn> VPN plugin failed: 1
May 23 22:18:14 NR5 NetworkManager[983]:    SCPlugin-Ifupdown: devices removed (path: /sys/devices/virtual/net/ppp0, iface: ppp0)
May 23 22:18:14 NR5 NetworkManager[983]: <warn> VPN plugin failed: 1
May 23 22:18:14 NR5 NetworkManager[983]: <warn> VPN plugin failed: 1
May 23 22:18:14 NR5 NetworkManager[983]: <info> VPN plugin state changed: stopped (6)
May 23 22:18:14 NR5 NetworkManager[983]: <info> VPN plugin state change reason: 0
May 23 22:18:14 NR5 NetworkManager[983]: <warn> error disconnecting VPN: Could not process the request because no VPN connection was active.

Before I started the vpn connection, the routing table looks:

Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.1.1     0.0.0.0         UG    0      0        0 eth0
192.168.1.0     0.0.0.0         255.255.255.0   U     1      0        0 eth0

After I tried to start vpn, the ip-address X.X.X.X from the vpn server was added to the routing table:

Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.1.1     0.0.0.0         UG    0      0        0 eth0
X.X.X.X         192.168.1.1     255.255.255.255 UGH   0      0        0 eth0
192.168.1.0     0.0.0.0         255.255.255.0   U     1      0        0 eth0

Also the same VPN-Connection works on the same machine under Windows without problem.

If you have some suggestions, I would be happy. Thank you a lot.

share|improve this question
    
Are you using point-to-point encryption in Windows? –  jmreicha May 24 '12 at 15:39
    
Seems to be a cross post of askubuntu.com/questions/141372/vpn-pptp-failed-1 –  kynan Jun 14 '12 at 21:04
add comment

2 Answers

up vote 1 down vote accepted

Your connection times out (LCP: timeout sending Config-Requests), which could be caused by your router not allowing PPTP connections to pass through from WAN to a host behind NAT. Check your router configuration whether PPTP pass-through is enabled and forwards to the machine you want to tunnel from.

share|improve this answer
    
Thanks a lot! A friend of mine had the same problem and we upgraded the firmware version of the router (Linksys WAG200G) and enabled IPsec and PPTP passthrough only leaving the other options unchecked (aka disabled). –  Kounavi Aug 23 '12 at 14:24
add comment

This helped me solve my problem in 12.04 and I hope it helps you as well. Copied from this Ubuntu wiki page

Run the following:

sudo apt-get install pptp-linux

Create file /etc/ppp/peers/YOUR_COMPANY with this content:

pty "pptp YOUR_VPN_GATEWAY --nolaunchpppd"
debug
nodetach
logfd 2
noproxyarp
ipparam YOUR_COMPANY
remotename YOUR_COMPANY
name YOUR_DOMAIN_OR_SERVER_NAME\\YOUR_VPN_LOGIN
require-mppe-128
nobsdcomp
nodeflate
lock
noauth
refuse-eap
refuse-chap
refuse-mschap

Add to /etc/ppp/chap-secrets:

YOUR_DOMAIN_OR_SERVER_NAME\\YOUR_VPN_LOGIN * YOUR_VPN_PASSWORD *

Create file /etc/ppp/ip-up.d/add-subnet with content similar to:

[ "$PPP_IPPARAM" = "YOUR_COMPANY" ] || exit 0
route add -net 192.168.100.0/24 dev $PPP_IFACE

In the above line, adjust subnet values (192.168.100.0/24) if needed

Then run:

sudo chmod a+x /etc/ppp/ip-up.d/add-subnet
  • Connect to VPN: sudo pon YOUR_COMPANY To disconnect, press Ctrl+C or close the terminal.

  • If you do not want to see VPN connection debug output, in file /etc/ppp/peers/YOUR_COMPANY delete 3 lines: debug nodetach logfd 2

In this case, “pon YOUR_COMPANY” will run as a background process. Use “poff YOUR_COMPANY” to disconnect.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.