Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Prior to upgrading XP to 7, my network worked fine. Now, the Win7 machine cannot browse the Vista computer or the PVR. Vista can browse Win7 fine.

In Windows Explorer on the left bar only the Win7 (Andy-PC) machine appears under 'Network'. On the right, the PVR (DX390) and Vista machine (Susan-PC) are there but only with the option to stream media. How do I fix this?

Windows Explorer - Network Devices View - Zoomed

share|improve this question
Are all of these devices in the same Domain or netbios Workgroup? You can check in (My) Computer properties, in the Name section or tab. – Paul May 24 '12 at 8:17
All machines are on the same workgroup. I have attempted to set up 7 with the same settings already in place since the rest of the network works well - even the Vista machine can access the 7 machine like it should – Andrew Heath May 24 '12 at 9:57

Windows 7 is notorious for that behavior towards older windows(XP/Vista)

Go to advanced network settings from network and sharing center.

Turn on "File and Printer sharing"

Turn off "Password protected sharing"

Turn on sharing for lesser cipher strength networks.

On the DX390 and Susan-PC, make sure you have shared the concerned files/folders correctly. If its your home network, just share it with Everyone.

As a last option, try ipmessanger. It will allow you to transfer files over LAN. It wont enable browsing folders though.

share|improve this answer
Sharing etc is all turned on already and lower encryption set. Must be something else. – Andrew Heath May 24 '12 at 9:59

It's fixed now. I war messing with the network permissions and firewall settings in Control Panel. I don't know which one did the trick, but after restart, all works fine.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.