Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I had downloaded snipmate from http://www.vim.org/scripts/script.php?script_id=2540... I extracted the zip file and copied it to folder /usr/share/vim/vim73/

Before this plugin,
i tried to install NerdTree then also copying the whole extracted zip folder it into vim73 directory didn't help much but
then i copied "NerdTree.vim" file to the vim73 folder directly.. then it started working...

I tried the same for snipmate but it didn't work out. Can anyone tell me why this behaviour and plus how do go about working out this plugin in vim?

share|improve this question
2  
How about you follow the installation instructions on the site and install to $HOME/.vim? –  Daniel Beck May 24 '12 at 18:11
    
I would recommed using pathogen to install Vim plugins. –  RanRag Aug 21 '12 at 19:30
1  
@RanRag Yo! RanRag you rock! –  mabus44 Aug 22 '12 at 9:14
    
@mabus44: Really you think by suggesting pathogen I rock than what's your say on Tim Pope :) –  RanRag Aug 22 '12 at 9:31

1 Answer 1

up vote 1 down vote accepted

Don't ever touch these folders and files.

Plugins are to be installed in ~/.vim (you must create this folder yourself) and settings are to be added to ~/.vimrc (you must create this file yourself).

And, next time you want to try a new plugin, read the documentation before you click on the download link.

share|improve this answer
    
I tried creating the folder .vim and the settings .vimrc in my "~/" folder but the changes done to the .vimrc file didn't show any kind of effect... thats why i got to know about this location /usr/share/vim where changes done vimrc were effective thats why i used this location for the plugins... Is there a way in which I can command vim to check the .vim folder and .vimrc file before starting? –  mabus44 May 25 '12 at 5:04
    
You don't have to tell Vim to use ~/.vimrc and ~/.vim/ because that's the default place for your settings and plugins. It has been like that for ever and the only way I know for Vim to start without using these is to explicitely tell it to do so by passing it a bunch of arguments on the command line. Just to be sure that we are on the same page, could you confirm that "your ~/ folder" is your home folder? ~ is a shortcut for /Users/username/ so you should have /Users/username/.vimrc and /Users/username/.vim/. –  romainl May 25 '12 at 6:04
    
"~/" is my home folder.. When i copied the snipmate contents of the extracted folder to ".vim" then the following error was shown when i tried to open a file "Warning in snipMate.vim: Snippet c) is already defined. See :h multi_snip for help on snippets with multiple matches. Warning in snipMate.vim: Snippet date is already defined. See :h multi_snip for help on snippets with multiple matches." Hence again the plugin is still not working.... Can you help to understand whats happening and how can i solve it? –  mabus44 May 25 '12 at 7:14
    
It means that SnipMate (or, at the very least its snippets) is installed in two different places and thus loaded twice. Get rid of one (the one that is located in the wrong place). –  romainl May 25 '12 at 8:42
    
Worked out pretty well thank you. –  mabus44 May 26 '12 at 17:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.