Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Lenovo Thinkpad T61 laptop. I had to wipe my hard drive clean and re-loaded window xp.

Under "My device manager" I can see Ports (COM & LPT), under this the printer LPT3 port is fine, but the Communication COM3 port has an exclamation mark against it. When I click the COM3 port the following message appears "Windows cannot determine the setting for this device. Consult the documentation that came with the device and use the Resource tab to set the configuration". Needless to say that I do not have the documentation that came with the device (if indeed it exists in the first place). The given detailes relating to the Device Type is "Ports (COM & LPT)" whilst the given Manufacturer detail is "Standard port types".

When I click the Resource tab, it shows the following settings:

I/O Range 03F8 - 03FF IRQ 04

I have already unistalled the port and then installed it again in case window xp could determine the configuration, but when I re-install the port it gives me again the same message. I rolled back the driver and updated the same, so it is not a driver issue, it is a configuration issue.

Also, I am not sure as to why the systems has automatically selected COM3 and LPT3 rather than COM1 and LPT1, which are not in use by any other application and which I would have thought to be the logical default ports. Anyhow, ports 1 or 3 is a minor issue. The most important point is can anyone please let me know what the correct configuration values for the COM port are?

share|improve this question
    
Since the T61 does not have these ports itself, you should specify which additional hardware is connected. Advanced (Mini) Dock? In this case you should check the settings of the ports in the BIOS setup (press F1 after power-on). –  Gurken Papst May 24 '12 at 16:58
    
Thanks Gurken. I do not know which additional hardware is connected, the laptop came as standard from IBM and I made no additions. If you can please point me in the right direction I will check accordingly. As to the BIOS, I have already checked this, but I found no relevant entry (again, I would be grateful if you could point me to the specific). I am aware that there is the "serial port" option in the BIOS, which was disabled. I enabled this, but made no difference to the end result, so I disabled it again. –  Redeave May 24 '12 at 17:30

1 Answer 1

According to page 59 of the Thinkpad T61 Service and Troubleshooting Guide the T61 does not have a DE9 RS232 serial port and nor does it have a DB25 IEEE1284 parallel port.

So far as I know, IO-addresses and IRQs are only really needed for the hardware associated with the old style DE9 and DB25 ports. The Wikipedia article for Parallel port lists typical IRQ and IO settings but, unless your computer is equipped with legacy port hardware of some sort, this is unlikely to be useful.

LPT1:  IRQ 7  0x378-0x37f
LPT2:  IRQ 5  0x278-0x27f
LPT3:  IRQ 2  0x3bc-0x3bf

Elsewhere are typical settings for Serial Ports

COM1:  IRQ 4  0x3F8 
COM2:  IRQ 3  0x2F8
COM3:  IRQ 4  0x3E8
COM4:  IRQ 3  0x2E8

Some devices, for example USB modems, provide a virtual serial port for which the device's drivers create a name such as COM3: These devices are not communicated with in the same way, so IRQs and IO-addresses should not apply.

share|improve this answer
    
Thanks RedGrittyBrick, I checked LPT3 and indeed this is on 03BC. If I change this setting I get an error message saying that the device is not working. As to COM3, I have tried 03E8 and indeed a number of combinations but it still does not work. I also changed to COM1, but still the same result. Please let me know if you (or anyone else) can think of something else. –  Redeave May 25 '12 at 17:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.