Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

On my computer I get this error -

could not start the print spooler service on local computer

error 1084 this service cannot be started in safe mode

the strange thing is, I'm not IN safe mode.

Anybody ever seen this?

share|improve this question

3 Answers 3

Found this - Windows XP THINKS it's in Safe Mode:

XP assumed to be in safe mode presumably because of the environment variable SAFEBOOT_OPTION that had been set to "NETWORK".

This can for instance be checked by selecting: start-control-system, selecting the tab "advanced" and pushing the button "environment variables". Scrolling the list of system variables should show whether the (cause of) the problem is the same, e.g. SAFEBOOT_OPTION being listed as having a value (whether NETWORK or MINIMAL).

If this is the case, then open the registry and look for every instance of "SAFEBOOT_OPTION" and reset the value from 2 to 0 (do not delete the key alltogether!). The 2 essential places where you will probably find the entry are HKCU - environment, and HKLM - system - currentcontrolset - sessionmanager - environment.

After rebooting however, the keys re-appeared until I removed the key OPTION(S?) at every occurrence of "Safeboot" under HKLM - Controlset001, Controlset002 etcetera, Currentcontrolset - Control - Safeboot (if I remember correctly, the OPTION key appeared under "Safeboot" next to "Minimal" and "Network" and had a value "NETWORK". For some reason that I was not able to determine, after rebooting, the system announced that during bootup it had experienced a severe exception error (I did not see it, however), but the system was fully operational thereafter anyway. After a second reboot, the error did not occur anymore and the services necessary to carry out Windows Update could be started again.

share|improve this answer

Go to Start > Run > type regedit and click OK

Then go to Edit > Find and search for SafeBoot

When the SafeBoot key is found in the registry there should be two subkeys, 'Minimal' and 'Network', if there is a third subkey 'Option', delete the entire 'Option' subkey and the problem will be solved.

Note: backup the registry first! (File > Export-> Save)

share|improve this answer

HKLM-system-currentcontrolset-control-safeboot-minimal-option

delete the option folder this will work

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.