Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a smart playlist configured to play my favorite podcasts during my commute. It's a list of audio-only, unheard podcasts:

Smart Playlist settings

In iTunes, I've ordered the playlist by Release Date -- i.e. I want to listen to the oldest podcast episodes first. The order is correct in iTunes but when I sync to my iPhone the order is jumbled.

Currently, I have five episodes in this playlist -- ordered by release date they're A,B,C,D,E. On my iPhone, they're ordered B,D,C,E,A. There's no sort order that's obvious to me -- not sorted by name of episode, name of podcast, length of episode, date added, etc.

Any solutions to ordering smart playlists on the iPhone?

Update: This is likely an iTunes 9 bug. There's lots of discussion about this over on Apple.com.

share|improve this question
    
I just installed iPhone OS 3.1.2 and it still doesn't fix this. –  Doug Harris Oct 8 '09 at 20:55
    
It looks like iOS4 finally solved this. –  Doug Harris Jul 4 '10 at 3:13
    
And I've created another similar playlist and have the same problem. It does seem to order by "modified date" rather than by "release date" -- so it's not completely random. –  Doug Harris Feb 7 '12 at 23:06
    
It looks like iOS 5.1 has solved this until Apple breaks it again. My smart playlist is actually ordered by "release date". –  Doug Harris Mar 9 '12 at 16:29
add comment

7 Answers

up vote 5 down vote accepted

had the same problem and found a fix suggested by a user somewhere else (it worked for me) - Olivier

"I did find another workaround that works better for me. If you create a smart playlist that is based on another smart playlist, then the track order of the former will be correct on the iPhone.

So what I did was to create a first smart playlist that included all podcasts. Next I created a second playlist where the first rule is that it contains everything from the first playlist (Playlist is). The result is that the second playlist is still updated automatically in iTunes, but it does not seem to get updated on the iPhone . . . and that's probably where the bug is. Anyway that second playlist will keep its ordering from iTunes.

This isn't quite as much of a pain as flipping the Live Update box on and off, at least for me. "

share|improve this answer
    
Just so crazy and it appears that it worked. This was mentioned in a post on an Apple discussion (discussions.apple.com/message.jspa?messageID=10420932#10420932). My new playlist has one rule -- "playlist is <original playlist". The new playlist is ordered correctly, the old one is still messed up. –  Doug Harris Oct 19 '09 at 14:13
    
I'm accepting this answer because it's a viable workaround. I still think this is a bug that Apple should fix. –  Doug Harris Oct 19 '09 at 14:14
    
And now, two weeks later iTunes has been updated to 9.0.2 -- not only is the core problem not resolved but the workaround is broken also! –  Doug Harris Nov 3 '09 at 15:03
    
iTunes 9.0.3 just came out with this promising bit in the release notes: "Addresses problems with syncing some Smart Playlists and Podcasts with iPod." Alas, the problem still remains. This workaround still works. –  Doug Harris Feb 12 '10 at 15:58
add comment

To make sure your smart playlists gets copied to your iPhone in the exact sort order you have done in iTunes, just right-click on the smart playlist, and choose "Copy To Play Order".

enter image description here

Re-sync with your iPhone, the playlist should now be copied and the songs will be in the exact order you wanted. Make sure to turn Shuffle off.

share|improve this answer
    
Didn't work for me. Not only that, but there's no indicator on the context menu next to "Copy to Play Order". Shuffle is definitely off. –  Doug Harris Sep 17 '09 at 20:04
    
There's not supposed to be any indicator. Just hit that "Copy To Play Order", and sync. Have you tried it? Did it sync? –  caliban Sep 17 '09 at 20:34
    
And by "Shuffle" off, I mean the iPhone's Shuffle function is set to off, not shuffle in iTunes itself. –  caliban Sep 17 '09 at 20:36
    
Yes, I tried it. Yes, all Shuffle functions are off. No, it did not keep the order. –  Doug Harris Sep 17 '09 at 21:33
    
Searched around the Net - there seems to be a bug with OS 3.1 that gets specifically podcasts out of order. Could this be the reason? theiphoneblog.com/2009/09/16/iphone-31-bugs-podcasts-order Also, there are users with similar complaints : discussions.apple.com/thread.jspa?threadID=2154509&tstart=0 –  caliban Sep 17 '09 at 21:41
show 4 more comments

MacWorld posted fix (http://reviews.cnet.com/8301-19512%5F7-10360396-233.html) turn off "live updating" for the smart list. Worked for me (Snow Leopard 10.6.1, iTunes 9.0.1 & iPhone 3.1)

share|improve this answer
    
Didn't work for me. Do you have "Play count is 0" in your smart playlist? When I disabled "live updating", the playlist completely disappeared from my iPhone. –  Doug Harris Oct 1 '09 at 21:46
add comment

I had this problem with iPhone OS 3.1 and iTunes 9... definitely seems like a bug.

In my case, turning off "Live Updating" on the smart playlist took care of it. Disabling that didn't have any effect on my workflow and just meant I needed to mentally keep track of where in the playlist queue I was.

share|improve this answer
add comment

This was fixed in iTunes 9.0.1 which was released today. Run the updater and you should be set.

share|improve this answer
    
Unfortunately, this was not one of the bugs addressed by iTunes -- I still have the same problem. My speculation now is that a new bug fix release of the iPhone OS will appear in the next few days and that will fix this. –  Doug Harris Sep 23 '09 at 3:58
    
I had to remove my podcasts from my iPhone and resync to get the ordering to properly sync. BTW, I sort by release date as well. –  Matt Haley Sep 23 '09 at 5:07
    
I unchecked "Sync podcasts", did a full sync and all podcasts were gone from my iPhone (as expected). I checked "Sync podcasts", did a full sync and all podcasts were restored. Alas, the order of my smart playlist was still random. –  Doug Harris Oct 19 '09 at 14:00
    
Not sure why it's still broken for you, playlist order has been fine for me since 9.0.1 was releasd. –  Matt Haley Oct 26 '09 at 5:09
add comment

I found another workaround for this issue: link 2 smart playlists and they can both have "Live updating" checked. This allows the playlists to update automatically when listening in iTunes or when you sync.

I have a "Good Podcasts" playlist that does all the hard work. It includes podcasts where the playcount is 0 and the where the podcast name is any of the podcasts I like to stay current with (about 30 podcasts). Then I have a "GP2" playlist where the only criteria is "Playlist is Good Podcasts." I manually rearranged both playlists (which, of course, have the same podcasts on them). When I sync to my iPhone, GP2 retains its order (and Good Podcasts does not).

The Live Update feature on the iPhone only works on the primary playlist, however. If I play one of these podcasts on the iPhone, its play count is incremented and it drops off the Good Podcasts playlist. However, it remains on the GP2 playlist. Obviously, the iPhone isn't smart enough to do live updating on GP2. This does not matter to me because I listen to the podcasts in order from the beginning of GP2.

share|improve this answer
add comment

Set the attribute "Media Kind" to "Podcast" in your smart playlist criteria.

This works for me, iPhone 3.1.2 and iTunes 9

share|improve this answer
    
I already have "media kind" is "podcast" and still the order is wacky. Thankfully, Olivier's solution is still working well for me. –  Doug Harris Apr 29 '10 at 14:08
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.