Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I installed the Roslyn CTP, and it worked beatifully for the most part. Then it was time to part with Roslyn, because some features I use aren't implemented yet, and Roslyn replaced the standard compiler. It may be too late for me, but for the afterworld there's still hope:

Is there a way to repair Visual Studio 2010 so it functions like before installing the Roslyn CTP?

Udate: I tried reinstalling Visual Studio 2010 Professional, to no avail. Now I'm investigating the error log, and it says:

CreateInstance failed for package [Roslyn.VisualStudio.VisualBasic.LanguageService.VisualBasicPackage, Roslyn.VisualStudio.VisualBasic, Version=1.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35]

Is there a setting I can change so Visual Studio uses the old compiler again?

Update 2: There would have been an on/off button in the settings.

Update 3: The on/off button doesn't show. Instead the settings pages for Roslyn stay blank.

Any help is appreciated.

share|improve this question
    
The quickest solution would just to repair your installation of Visual Studio using the installer. –  Ramhound May 25 '12 at 13:16
    
Tried that first, didn't work. –  lowerkey May 25 '12 at 14:18

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.