Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When some bad sectors ( literally 5 ) appeared on my previous HDD, I decided to replace it. I decided to clone whole drive using dd (run from GPartEd) in do-not-stop-on-read-error mode. That is:

 $sudo dd if=/dev/sda skip=0 of=/dev/sdb seek=0 \
 conv=sync,noerror,notrunc bs=512 count=460M

After successful operation I've put my new HDD into my laptop as it's main drive. Of course, the C: partition on new drive is still marked as if it had bad sectors. I understand this: all ifnormation including information about bad sectors on partition has been copied. GPartEd shows this with exlamation mark in yellow triangle. In partition information in GPartEd, there is instruction to run chkdsk /R /F on Windows and reboot twice. Problem is - it doesn't help even though chkdsk detects no errors on disk.

So here is my question: Is there some way to force the removal of "bad sectors flag" from that partition ?

share|improve this question
    
The best way would have been to solve those partition errors prior to the cloneing process –  Ramhound May 25 '12 at 14:17
1  
And what magic tool, pray tell, solves bad sector problems on a drive before copying data off it? –  Mark Sowul May 25 '12 at 20:16

1 Answer 1

up vote 3 down vote accepted

How about chkdsk /B?

/B NTFS only: Re-evaluates bad clusters on the volume (implies /R)

share|improve this answer
    
Yes, this is it. Thanks a lot ! –  malloc4k May 25 '12 at 19:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.